Automatic Airplane Mode on Lid Closed

Hi, I’m using Clear Linux , version 39720, on a HP laptop (HP Laptop 15-dw2xxx, Intel 10th i5 1035G1, Nvidia mx130, nouveau driver).
I don’t have any power saving option enabled (at least as I can see in gnome Settings).
Every time I close the lid, airplane mode goes on. When I re open the lid the airplane mode is still on.
I’ve tried many fixes online, but none of them helped me.

Here the list of commands I’ve tried:

gsettings set org.gnome.settings-daemon.plugins.power airplane-mode-on-lid-close false (error because of airplane-mode-on-lid-close key missing)
sudo nano /usr/lib/systemd/logind.conf.d/50-lidswitch.conf, > HandleLidSwitch=ignore 
sudo nano /usr/lib/systemd/logind.conf.d/80-lidswitch.conf > HandleLidSwitch=ignore

I’ve also tried the instruction on the 50-lidswitch.conf with

sudo mkdir -p /etc/systemd/logind.conf.d
sudo ln -sf /dev/null /etc/systemd/logind.conf.d/50-lidswitch.conf

I’ve tried also to install gnome-extension “Sane Airplane Mode” but didn’t solve
I would like to disable this “feature”.
Forgive me for my bad english, I thank you in advance for any response.

Did you try this one?

If the command “sudo /usr/bin/setkeycodes e057 240 e058 240” disables the behaviour, then the above link would work on Clear Linux.

Yes, I also tried that guide but it didn’t work.
Fortunately , your code seems to have fixed the issue.

Thank you @Tidda.
Update : now , when the lid is closed the devices is still connected to WiFi, but just as I open the lid , airplane mode goes On. Maybe there’s stil something that i am missing or it could be a bug?