BIOS freezes upon boot - message "SHA256 validated"

I use Clear Linux on a Intel NUC8i7BEH with most recent BIOS from Intel.

Since yesterday system Clear Linux installed on second SSD doesn’t boot anymore.

A new line/message on top left corner appears: “SHA256 validated”. Then booting stops. Pressing key F2, F7, F10 etc. to enter BIOS doesn’t work anymore. Only hard power-off pressing power button for more than 4 seconds.

Before Clear Linux booted with no problems. Didn’t change BIOS settings. Only software updates.

Can enter power-switch menu pressing power button for 3 seconds. From there I can choose second installed Fedora on primary NVME and boot into Fedora.

How to get back booting into Clear Linux?

Addition 1: When message/line “SHA256” appears on left top corner keyboard seems to be switched off, powered off, not connected. No LED for NUM lock. Key combination ( Ctrl + Alt + Del ) not working.

1 Like

Same problem here !

I found another temporary fix :
on boot, press F1, and a menu appears where I can choose the old kernel
then I can boot the system to a normal state.

But I have to make that at each reboot… so only a temporary solution

1 Like

What is the version of kernel that is working and what is the version that is not working?
That could help narrow down what changed.

The working kernel :
5.2.11-829.native #1 SMP Thu Aug 29 00:11:53 PDT 2019 x86_64 GNU/Linux

Where I can found the new kernel without rebooting (it’s a production machine) ?

$ sudo clr-boot-manager list-kernels

I have the same issue:

  • 5.2.15-834 is working
  • 5.3.1-838 is having the bug
3 Likes

You can set the kernel at the boot:

Get the kernel name from this:

Then configure it for next boot:

sudo clr-boot-manager set-kernel <kernel working>

You will have to also stop the auto update

sudo swupd autoupdate --disable

But this should be temporary :wink:

2 Likes

This implies that system is booting/booted and console for command “sudo clr-boot-manager” is available, but my system ClearLinux is not booting anymore. So how should I execute clr-boot-manager with a non-booting ClearLinux?

I wanted to fix it as a broken system according to https://docs.01.org/clearlinux/latest/guides/maintenance/fix-broken-install.html

Therefore I downloaded clear-31090-live-desktop.iso.xz and wrote it with Etcher on a USB stick. It is not booting. Same Problem: line “SHA256 validated”. Then booting stops.

So what to do? How to get a booting ClearLinux?

Same here. But the 5.2.15 works fine!

If it has booted before you should be able to get to the systemd-boot selection menu (press space during boot since we disable the timeout by default). From there you should have the previously booting kernel available to select.

Since there are multiple sightings of this problem, I’ve logged a bug on GitHub here:

Please continue to provide any information you may have.

1 Like

Thank you. This works. Kernel 5.2.17-836.native boots. Kernel 5.3.1-838 doesn’t boot.

Just to clarify, add infos:
Downloaded https://cdn.download.clearlinux.org/releases/31090/clear/clear-31090-live-desktop.iso.xz
Flashed it with Etcher https://www.balena.io/etcher to a USB drive.
Boot from this drive.
New line on top left corner appears: “SHA256 validated”
Booting stops.
Pressing space during boot doesn’t offer choice for different kernel versions.
So Clear Linux live 31090 not usable/installable on my Intel NUC.

For me, it’s F1 to use for the menu.
Can you try it ?

Same problem here with Intel NUC

For me it was space to get the menu to go back to old kernel

then I did this
swupd verify --fix -m 31080 --picky
to go back to old version
then
swupd autoupdate --disable

working fine and booting up normal in 31080 for now

will wait for further info before upgrading

1 Like

Just to clarify, pressing space to get the bootloader menu has to happen some time before the “SHA256 validated message” appears. You can start smashing it repeatedly while the BIOS splash screen fades out.

Just a quick update.

  1. As of Clear version 31110, we have gone back to kernel 5.2 until we can root-cause the underlying problem with the 5.3 kernel on some platforms.

  2. Per @miguelinux, the “SHA256 validated” message is only a successful message from systemd-boot. It will be removed to avoid any confusions.

1 Like

Another update on this from https://github.com/clearlinux/distribution/issues/1272 : the bug has been identified, fixed, and kernel 5.3 re-released.

If you disabled autoupdate to workaround this issue, update to the latest Clear Linux version and please let us know if you continue to see the problem.

Yes. Updated to Latest server version: 31150.

Now it boots as before without the need of any manual intervention. As usal.

(And I got Gnome 3.34.0. Nice.)

Thank you.

1 Like

Thanks for the quick fix on this!
I also had this problem on a NUC8i5BEK NUC. I need the box to be up so I had installed another distro, on 25 Sept 2019 to get it working, but re-installed Clear Linux on 04 Oct 2019 and all is good.

Incidentally, Intel pushed out a new bios on 16 Sept 2019 and I flashed that before re-installing Clear, and I thought that was what fixed my issue, so it’s good to know where the problem was, and the actual fix.

Thanks again to the Clear Linux Team!

1 Like