Boot issue with gnome (startx)

I have various issues when trying to load Clear Linux. I have messed up the gnome environment when I encountered problems after an update and tried to reinstall the desktop. Swupd repair and swup update do not fix the problem. I now boot Clear Linux in text mode without autologin. ‘startx’ brings a white screen with “Oh no! Something has gone wrong!”

(1) Is it possible to repair the boot process with swupd or another command ?

(2) Is is possible to reinstall Clear Linux without erasing the filesystem?

(3) I have a strange issue with the installer: it says “found multiple CLR_BOOT partitions.” But I have only one CLR_BOOT fat32 partition, along with an EFI_BOOT fat 32 and a MBOOT multiboot ntfs (Windows 10) partitions.



have you tried
sudo swupd repair -V 40250 --force --picky
if you find yourself coming across a white screen with Oh no!, you can use Ctrl+Alt+F5 to go to a TTY

I can’t say anything about 2 and 3 I’m afraid. I’m not experienced enough.

1 Like

Thank you for your answer.

Yes, I have tried sudo swupd repair, many times, but I had only access to a virtual console (tty1 if I remember correctly) after login.

I have access to the other virtual consoles using Ctrl+Alt+F(1-6) for each tty virtual console, but Ctrl-Alt+F7 gives nothing. Usually, tty7 is reserved for the graphical environment on top of the tty7 virtual console (if I understood correctly).

In the other ttys the gnome service (gdm) was of course not started, as indicated by “systemctl status gdm” and I encountered some problem when I tried to start it with “systemctl start gdm.service”

I am now trying to reinstall Clear Linux.

(2): I have finally erased my previous CL filesystem with “sudo mkfs.ext4 -L CLR_ROOT /dev/[myCLpartition]”

(3) I have erased the EFI_BOOT fat 32 partition; the error disappeared and the installer proceeds to the installation.