Installation in VirtualBox/live image issues


I’m pretty new to Clear Linux, but really interested in this project, but having issues installing the OS in virtualbox (just to try it out). I tried to follow your guides, installing from live img or launch a live img, but i’m having problems with the Gnome desktop.

Actually my host OS is Ubuntu 16.04, and running the latest version of VirtualBox (6.0.8), also launched your check script if i could install clear linux, and everything goes fine, except the EFI firmware, what’s missing. (but i don’t think it’s relevant to the virtual machine, maybe I’m wrong here?).

After setting up the root account and chaning the kernel to lts, and installing the guest additions everything goes fine, than i tried to install the desktop-autostart bundle, and was expecting to have the gnome interface after reboot. Instead of I’m getting only the terminal. I tried to launch startx which launches the gnome desktop, but it launches an older version, that’s not fully functional. Also with autostart it should be launched automatically?

Also tried to install the distro from the installer, but instead of finding the gnome desktop with the installer I’m getting the terminal.

I’m pretty sure that I did all the steps of the tutorials to install the distro, but without success.

What I’m doing wrong?

Thanks for your help,

Try running systemctl enable gdm.service and then rebooting.


i tried it, but it does not work. Also gdm.service is up and running correctly.

For the last try i tried to install it from the Live img, changed kernel and installed Guest Additions.
After that step installed the desktop-autostart bundle, everything goes fine, but on reboot im getting a black screen, so with alt +f2 i log in as root. At this point i tried to do as you said, reboot but did not help, same result.

Any more ideas? Thanks!

Hi Bex1990, the instructions for using VirtualBox are currently being revised so maybe this will help. Download the live-desktop-iso image from and then decompress the image with unxz clear-29620-live-desktop.iso.xz and then follow the instructions to create a new VM from the document

Be sure to check the enable EFI option on the system tab for your new VM. I also recommend setting the disk size to 32GB. Attach the ISO to the VM as documented and then start the VM. It may take a minute or two to boot (we are looking into a boot issue with the VM) and then you should see the live desktop running the gnome desktop with the Clear Linux Installer (the Clear Linux logo) in the application tray on the left hand side. The VM should be configured for the network.

At this point you should be able to follow the instructions for installing from the installer using the instructions in this document:

Once the installation is done, return to the VirtualBox instructions where you unmount the installer ISO here:

I know this is not the most elegant instruction but it should get you going…


Thanks for your help, last night i was able to install and start clear linux with Gnome, it was a bit tricky, and (as you said it’s being revised) the instructions are lack of some information.

After all, i used the installer img (from this guide:, but the live desktop would never start. (waited at least 5 minutes). Also I noticed that in the available bundles I could not find the clr-installer-gui but the installer without gui was already there, so I could install the OS from the textual installer.

After installation and reboot (selected the lts2018 kernel for VBox) i was able to install the guest additions without any issue, rebooted and the Gnome desktop started without any issues, but later on (after login) i got a black screen and I was not able to use the GUI anymore…

After digging trough logs (mainly dmesg and X logs) I noticed that I had a Glamour initialization failed error, so i turned off VBox and flagged the 2D Video Acceleration and 3D acceleration in settings, rebooted and everything was fine.

I don’t know if this info could be useful for you guys, but maybe others that has trouble installing CL in Vbox could use it.

Thanks again,

Glad to hear you were able to get it to work. Also appreciate all the additional info you gave us, we’ll look into it.

I managed to get it to work by checking the “use 3d acceleration” option in virtualbox! I installed through the command line by pressing control-alt-f2 or f3 during launch because it wouldn’t boot into gnome on vbox (systemd unable to write it’s required files).

Good luck!