Cannot Install Clear in VM on VMWare Vshpere

I am trying to set up a vm to test Clear linux on our VMWare ESXI HA cluster but I can not get it to boot to allow me to install clear-36010-live-server. Did I forget to enable an option? I have EFI and Expose hardware assisted virtualization to the guest OS enabled. I can provide more information if needed.

Last I tried vmplayer-free on CL it would not build the kernel module, and personally I don’t like the way the install works…it defaults to /usr and not /usr/local. Have you given virt-manager a shot? That works really well with CL

– whoops, I see you’re running a totally different scenario. But maybe something of value there for someone else. :wink:

1 Like

I am assuming you followed the existing install requirements that are published. All I can offer is to either download a prior build to install and the run “sudo swupd update” to reach the current build or download a later release past 36010. That worked for me. For reasons unknown 36010 just gave me nothing but trouble when setting up in a VM. I simply went to the “other downloads” link and pulled the latest build.

1 Like

With recent versions of vSphere, Clear has trouble initializing the display on non-desktop installs. I’m not sure why this is, but if you use the kernel boot parameter “nomodeset” it’ll run appropriately. For my Clear server install on vSphere 7.0u3, I had to append nomodeset to both the install disk boot options and the boot options on the installed drive. Here’s the issue on GitHub that alerted me to the boot option: kernel 5.15 freeze during boot · Issue #2500 · clearlinux/distribution · GitHub


I removed the quiet and added nomodeset from the kernel boot options and it works great. Thank you!