Clear Linux on VMWare?

Hi all,
As anyone tried to get it running on Vmware (Windows) recently?
The live iso runs but installation from there does not work for me (it cannot boot afterwards).
The installer iso kind of works and boots into a terminal but after installing the desktop and the i3 bundle I only get a black screen with a pointer and no way to get to a terminal.
Any suggestions?

Are you using VMware Player or VMware Workstation Pro? What version?

If you’re getting a black screen, can you switch to another terminal (CTRL+ALT+F3)? If so, instal the os-cloudguest-vmware bundle which has the open-vm-tools.

It looks like our documentation is referencing an old installer.iso and VMware player version so we need to get that refreshed.

For the live-desktop case, check how much RAM is assigned to the VM. I noticed the desktop won’t start with the default 768mb. Bumping up to 2GB fixed it.

Pro Version 14
I tried to get to a terminal but that would not work. Will double check that.
What is the recommended way to install on VMware?

Thanks for clarifying. We don’t have documentation on using Workstation Pro, yet.

I would recommend starting with the server ISO from here: https://clearlinux.org/downloads and doing a minimal install to reduce the complexity. Once CL is installed in the VM, add the os-cloudguest-vmware bundle.

Still make sure the VM has EFI boot enabled.

1 Like

Thanks will give it a try. From my past experience with Linux on VMware I would not expect to a difference running it on VMware pro

I have VMWare Workstation 12 Pro. I downloaded the VMWare image and followed the instructions. It would not boot.

Relevant messages

PXE-E53: No boot filename received.

Operating system not found.

Did you enable EFI firmware?

Interesting, I did put this line

firmware = “efi”

at the bottom of the .vmx file. When I look for it this morning, I don’t see it there. So, I put that back in and saved the file.

Now when I try to power on the machine, VMWare just gives me a message, “Dictionary problem”.

There are 3 issues I had, efi hardware, X11 default drivers, and mouse grabbing.

Early in the .vmx, add the following:

For efi hardware support add:
firmware = “efi”

For X11 issues:
mks.enableMTLRenderer = “0”
mks.enableGLRenderer = “1”
mks.gl.allowBlacklistedDrivers = “TRUE”

For mouse grabbing/ungrabbing add these lines:
mouse.vusb.enable = “TRUE”
mouse.vusb.useBasicMouse = “FALSE”

I downloaded the .iso and created a virtual machine. I followed the instructions exactly on the website, and it worked, but the instructions say to set the disk size to 8G, and when I was finished, there was not enough room to unzip the VMWare Tools. Ouch. I shut down to expand the disk, but it was not responsive, so I forced a shutdown, then expanded the disk in VMWare. But of course now I have to expand the partition (or, something like that) inside the VM. This would not deter an experienced Linux user, of course, but I am still learning. Installing this distro is a bit rougher than what I’ve experienced with Mint and Pop. I will have to set this aside for now, maybe come back to it later. Best of luck to the Clear Linux team.

Ooof. I understand your frustration there. Just FYI we’re aware and planning on changing that recommendation in the documentation to be higher: https://github.com/clearlinux/clear-linux-documentation/issues/533