CL 33590 install setup on VMWare Workstation 15.5 - Manage User

I tried installing the latest CL 33840 guest OS on VMWare Workstation 15.5 running on Windows 10 Ent LTS (1809) using the clear-33840-live-desktop.iso. I had a problem after doing the install (Verify succeeded) and running the “Install Clear Linux” desktop app. It got to the “Manage User” screen and I keep getting “Password does not contain enough DIFFERENT characters.” And thus can’t complete the install process.

So I tried it with CL 33590 and get stuck at the same place.

Yes I did select the “Virtual Intel VT-x/EPT or AMD-V/RVI” flag for processor and added the ‘firmware = “efi”’ to the end of the vmx file. So in both cases the VM boots into the new CL image from the iso file but I can’t complete the installation process because I am blocked at this step. I have tried every conceivable username/pwd combination including rediculously long and complex pwd’s and always get the same error message (actually the error doesn’t show until you select “confirm” and right before the page closes you can see yellow text that something happened and if you go back to “Manage User” step you see the error message displayed.

Does anyone know what causes the problem and what the solution is? It seems like people have reported getting 33590 working on VMWare Workstation, though I haven’t seen any say specifically they succeeded with 15.5

Plenty of other Linux variants installed fine, not sure what is the deal with ClearLinux. “Clearly” something isn’t quite right, LOL.


does you password contain letters, numerals, and symbols?

Yes all of the above and is more than 8 characters. The troubling thing is that the initial entry of the password and ‘confirm’ password does not complain about a problem. It’s only after the “Confirm” button is selected that the password gets flagged as invalid. If you don’t pay really close attention you wouldn’t even notice it was rejected because the “Confirm” closes the dialog page. But going back into it you see the yellow error message about the DIFFERENT characters. It is acting like the problem is not related to characters, more like another check is going to force failure regardless of the password contents, believe me I have tried some of the longest and most secure passwords imaginable and they ALL fail.

you should report this to clearlinux/clr-installer on github

Thank Doc, I somehow was able to get past that problem now. It actually looked like it flagged the pwd as unacceptable but now actually let me proceed with the installation. I’m further along now - through the initial installation but I think the problem reported is a bug, though possibly just on VMWare Workstation.