Computer boot up in BIOS?

I use a MSI GE70 and have installed the OS. But when booting up after installation it boots up in BIOS every time. Have tried to change boot priorities in BIOS, but without any succes. What am I doing wrong?

To clarify, after it boots to your system’s EFI/BIOS can you manually boot Clear Linux from it? Or is it just not working?

Here are some things that come to mind:

  • Check for any and apply any available BIOS updates. We’ve seen lots of weird EFI/boot issue simply resolved by doing that?

  • Set boot priority to your internal hard drive

  • Try unpluging any extra devices, especially USB.

  • Run sudo CBM_DEBUG=1 clr-boot-manager-update and share the output.

Thanks a lot for answering, puneetse.

Yes you are right: whatever I do (make adjustments in BIOS and setting boot priority to internal HDD), the computer keeps booting into BIOS.

I will try the first and the last of your suggestions and report back. Have a nice day. oleriis