Disable mouse acceleration

Anyone knows how to do it and wanna share? On ubuntu, I used to disable it through xinput, which is not natively installed on CL_OS. I don’t even know if CL_OS runs on X or Wayland, or whatnot.
Ps: If you’re thinking about saying anything related to messing with the mouse speed setting, please don’t.

I believe you can find a section in gnome-tweaks about mouse acceleration.

True, and I’ll try it if I can’t find how to do it through the terminal, because 'gnome-tweaks simply didn’t work when I tried it on ubuntu 19.04.

As @doct0rHu said, gnome-tweaks can also be used to edit the /gnome/desktop/peripherals/mouse/acceleration-profile

An alternative is installing dconf-editor

On Xorg, there are several ways of setting mouse acceleration :computer_mouse:

Edit the Xorg configuration with xorg-xset and xorg-xinput, each installable as a package

If Clear Linux runs on Wayland, instead of xinput you’d use libinput

https://wayland.freedesktop.org/libinput/doc/latest/normalization-of-relative-motion.html#motion-normalization

The FAQ for libinput
https://wayland.freedesktop.org/libinput/doc/latest/faqs.html

2 Likes

Thanks. It’s running X11, so I installed x11-tools, and disabled it through xinput.

Does gnome-tweaks not working?

I don’t know. It’s just that it never worked with me, so I avoid it if I can.

1 Like

I use it all the time on clearlinux. Please try it, we don’t inherit all the bugs from Ubuntu :).

1 Like

That has been true so far and I must say I’m positively surprised.