Easy way to enable "numpad" in gdm-login screen?

Hi there!

First post here…so i guess i should say “hi” :slight_smile:
Quick question: How to convince clear linux to auto-enable the numpad in gdm + in gnome itself?
I suppose that

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

Should do the trick, but it seem like this cmd is not working as expected.

Cheers

The x11-tools bundle contains numlockx which may do what you want.

https://wiki.archlinux.org/index.php/Activating_Numlock_on_Bootup

Thanks for your link!

But I confess that I am little stuck.

I got numlux installed, and I solely did this:

then add the following code to [~/.xprofile]:

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

Done, I rebooted -> numlock still not active at login but active in Gnome…1/2 way solved :slight_smile:

But how to enable numpad in gdm…this ~.xprofile can’t be the right file to do so.

In the wiki I read a of tool called “gnome-session-properties” how to install that in CL?

Cheers.

Is this only happening to me -numpad deactivated in gdm+gnome- or can others confirm this behaviour…just curious to know

Try placing that code snip-it in /etc/xprofile rather than ~/.xprofile

Sorry, I tried this with xprofile in /etc but this does not help. May I ask: is -on your pc- numpad active in gdm by default?

I attempted multiple things to get numlock on for gdm. I confirmed /etc/xprofile is indeed executed, but something must turn off numlock after. My numlock is on after login. However, all of my attempts to have numlock on after gdm has started, have failed.

I use lightdm and it is easy to get numlock on with lightdm. However, I do not recommend switching if you like gdm.

Google-fu:

TL:DR; try

sudo gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Untested :slight_smile:

Secondary, check your BIOS settings. Many BIOSs nowadays have a setting to enable NumLock at boot automatically.

@ahkok
I checked the bios, good idea btw, but no there is no option for numpad.
I found this askubuntu -link before asking here, but this does not work here on my system, so I thought I’d ask here as this seemed to be a CL issue -not sure after reading some forums.
Anyway when I follow askubuntu I get following:

gdm@robotnik/root $ gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

(process:1938): dconf-WARNING **: 22:16:12.070: Unable to open /root/.local/share/flatpak/exports/share/dconf/profile/user: No permission(->This file does not exist!)

(process:1938): dconf-WARNING **: 22:16:12.076: failed to commit changes to dconf: Fehler beim Erzeugen der Befehlszeile(Cannot create commandline) »dbus-launch --autolaunch=38e2d3436d07480681b388d1e3c85d2f --binary-syntax --close-stderr«: Der Kindprozess wurde mit Status 1 beendet(childprocess -> endstatus=1)

(some comments+translations added)

Does this make any sense to someone?