I believe I found a bug

A bug I can reproduce

This is how I did it

Using latest build

In gnome set auto login
Restart to check it works


Login using kde

Lock screen ( important part, make tea/ coffee )
Try to unlock screen with login password
This fails even though you have made it visible and checked.

Click the switch session button
Click your user name

And you it automatically logs you in your gnome session without password


My first thought is that the auto login would need to be established for the KDE session within the KDE session. The default installed DE is Gnome and it’s my belief that when autologin is setup for Gnome is would absolutely not be shared with KDE.

Beyond that, I’m a Clear Linux newb and won’t be too much more help. But I do have experience in KDE and Gnome. Before plasma, KDE was my favorite DE.

Yes I will log back in to gnome later and turn off auto login

But it is interesting that after locking the screen in kde that you can unlock again by switching sessions

Ian, I think that’s classic multi user environment. You’re simply accessing it from the same terminal. When you leave, you lock that session but the computer goes on. A linux OS is a lot more like what people think of when they say “server”.

My laptop is probably 30 times more of a computer than our server was when I was in college in the 90s. Back then, my 486SX-25 really was a personal computer! :slight_smile:

Are you still using GDM, or is GDM.service still running?

Well I log out of gnome

Not checked to see if the service is still running

What would be a good way to check ?

My guess is gdm is still running, which is different from desktop environment such as gnome or kde.

Run systemctl status gdm to check whether this is still running.

Yes GDM is still running

Now I have sorted one issue

Logged back into Gnome, and switch off the auto login for my account

So that now stops the autologin when at the locked screen

But I am still having issues of not being able to login from the locked screen KDE
Even though I am typing the correct details

Would gdm still be stopping this ?


Default login manager of KDE is sddm, try that.

And I suppose you already disabled gdm.service

I believe I have will check again once in front of the computer

So what would be the best way to disable GDM?

As I am using sddm and kde ?


systemctl disable gdm

Right I will try this when I get home

Been away for a few days

Thank you doctorhu

Also, systemctl status sddm.service to check whether it’s enabled and running. If not then enable and start it.

Confirmed that gdm is not running

Let’s see if I get locked out now

Thanks everyone

Will message back soon

Confirming I am still being locked out on the kde session screen

Just will not accept the correct password

And even starting a new sessions logs me in

But kde desktop does not load

Just a black screen

What do you mean by just a black screen? Have you started sddm service?

Hi Doctorhu

Once I started a new session as that was my the only way for my password to be accepted

Black screen, sorry not very descriptive

Kde desktop or taskbar do not load

But the apps I have in autostart load up

But once closed I have no options to do anything

As have no menus or icons

But I can see the mouse icon

Only way to log back in is to restart the pc and log in from fresh

At the moment I have turned off screen lock

But not that’s not an ideal situation

Even after a manual screen lock I can’t get back in

Report this to GitHub issue then.

Ok I will raise it there

Thank you