Issue while locking screen when using KDE

On fresh installs lately I was hoping to change the original desktop to the desktop-kde, when while using, every time screen locks, it fails to unlock with the user password, forcing me to reset the machine to be able to keep using it, can it be sddm issues? gdm seems to be gone for now, has anyone had the same issues?

Check sudo journalctl after unlock fails and see if there are PAM errors, or anything relevant.

"pam_unix(de:auth): authentication failure; logname= uid=1000 euid=1000 tty=:0 ruser= rhost= user= (my user) "
Only thing that pops out at the time

@anselmolsm looks like we still have incorrect PAM files. Note the de session here - it probably needs patching to use sddm instead.

This one was bugging me for awhile, it broke when Linux-PAM was changed to autospec and I happened to solve it yesterday. I did wonder if I was the only one and it was just customizations I’d made since no-one else was reporting it.

The problem is solely that /usr/bin/unix_chkpwd was no longer installed due to Linux-PAM being more split now and it not being in a bundle to pull in all the pieces. I fixed it by adding the sddm bundle (which has Linux-PAM in its bundle).

So it can be fixed easily by adding Linux-PAM to the desktop-kde bundle. Can also switch the sddm packages in desktop-kde to use the sddm bundle at the same time as well.

1 Like

so… im kinda new to clear linux so, can you show me how you solved it? can I make it myself?

Thanks @sunnyflunk for pointing this out. desktop-kde should already be including sddm bundle at this point, will fix that.

@Alef_Santos, based on what @sunnyflunk said above, swupd bundle-add sddm should fix it for now. The actual fix will come in an update later this week.

1 Like

thank you so much for the attention, really great to see this kind of support from you guys, its all working now :grinning:


will fix that

Released in 31380.