Where is the setting for (GNOME) Login Screen Keyboard Layout?

Where is the setting for the keyboard layout of the login screen?

The GNOME login screen does not have the option to change the keyboard layout, and it uses the secondary layout (us) rather than the primary layout (dvorak) even though my /etc/X11/xorg.conf.d/00-keyboard.conf is:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "dvorak,us"
EndSection

gdm uses x11 keymap instead of the keymap set in gnome.
to set x11 keymap, use localectl. See localectl --help

(as for your 00-keyboard.conf, it seems to be in the wrong format. the correct format for dvorak would be:

Section "InputClass"    
        Identifier "system-keyboard"    
        MatchIsKeyboard "on"    
        Option "XkbLayout" "us"    
        Option "XkbModel" <model>    
        Option "XkbVariant" "dvorak"    
EndSection    

<model> is the keyboard type, i believe the default is pc105 )


1 Like

@cleart, I reformatted my initial post. Does that resolve the “wrong format”?

i dont think so
(filler)

@cleart , yes indeed. I do not edit the file /etc/X11/xorg.conf.d/00-keyboard.conf. Rather, it was the result of the command

localectl set-x11-keymap dvorak,us

. Then,

localectl set-x11-keymap dvorak

updates the file /etc/X11/xorg.conf.d/00-keyboard.conf
to

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "dvorak"
EndSection

However this does not change the login screen nor the consoles, which remain in US QWERTY.

set it like this: localectl set-x11-keymap us pc105 dvorak

for the consoles: localectl set-keymap dvorak

1 Like

Ah that gives me a 00-keyboard.conf that resembles yours. Will try it out.

Thank you!

please give feedback (did it work?), and please change category to Q&A

did it work?
(filler)

localectl set-x11-keymap us pc105 dvorak 

did change the login screen as well as the virtual consoles. Thank you!

1 Like