N Terminal mode, the keyboard Layout not respected

I use the “French Canada” keyboard with Canadian English setup and from within Gnome, that works as it should.

However, if in lieu of logging into Gnome, I enter terminal mode directly (ctl-alt-fx x =1,2,3,4), the keyboard is us standard.
I have used localectl set-keymap ca, and also localectl set-x11-keymap ca.

localectl status
System Locale: LANG=en_CA.UTF-8
VC Keymap: ca
X11 Layout: ca

However, CL ignores the keyboard mapping (eg, ca, cr, or what ever), the interface remains keymap us
Is there a work around?

When I do not log into Gnome, but go direct via ctl-alt-f1 or ctl-alt-f2…
the keyboard layout is set to US, and I am unable to change it to Canadian french, even though localectl status says it is different.

I needed to visit gnome keyboard settings and choose the Canadian French Keyboard from within GNome.
Thereafter I can avoid gnome and log in directly
To be sure, sudo localectl status
sudo localectl set-keymap your_keyboard_layout
sudo localectl set-x11-keymap your_keyboard_layout