Has anyone had any luck extracting .deb and .rpm programs into Clear Linux?

I have seen some comments on these forums saying it’s doable but extracting to the same folders in the root directory hasn’t worked for me. The programs appear in the menus as installed applications but don’t start up when I click on them.

I’m thinking if we had a guide detailing the difference in file structure from these formats to getting them to work on Clear Linux it would be helpful in getting more use from the OS.

1 Like

Linux uses shared libraries, typically located in /usr/local/lib , /usr/lib , or /usr/lib64 (in AMD64/AArch64 systems). (Note: /lib and /lib64 are often linked directories to /usr/lib and /usr/lib64 due to systemd changes.) These libraries are utilized by all the software installed on your machine. Normally, your package manager (e.g., apt, yum, pacman) resolves all program dependencies automatically when you install software from it. However, if you’re running third-party software, it may or may not run out of the box, and you might need to take additional steps.

One crucial shared library is glibc. This library is essential for virtually all programs on your system. If you have software that requires a glibc version older than the one on your system, that program will likely not run.

How does Linux find these libraries? By default, it uses the configuration in the /etc/ld.so.conf file, and potentially additional configurations in the /etc/ld.so.conf.d/ directory. To see the current configuration for the dynamic linker, you can run ldconfig -v .

How can you check if a program has all its necessary libraries? You can use the ldd command followed by the program name. It will output something like this:

ldd /usr/bin/bash
    linux-vdso.so.1 (0x0000ffff9f5f3000)
    libtinfo.so.6 => /lib64/libtinfo.so.6 (0x0000ffff9f3b0000)
    libc.so.6 => /lib64/libc.so.6 (0x0000ffff9f1d0000)
    /lib/ld-linux-aarch64.so.1 (0x0000ffff9f5a6000)

This output indicates that bash can run on your system because it has found all the necessary libraries. This is a crucial first step before attempting to run a program. Even if all the libraries are present, there might be additional configuration steps required, such as setting environment variables or adjusting permissions.

NOTE: Put here the software you want to install to help better.

1 Like

Thanks for the clear explanation.

I had some success installing the internxt drive for Linux based on the Debian version which seems to be working fine, however 2 apps which I was trying to run I’m still having some issues with.

The first is Codelite. After running ldd /usr/bin/codelite I recieved a long list of dependencies but the one missing was libtiff.so.5, which I don’t know how to install as I couldn’t find libtiff in the swupd search.

The second is Presonus Studio One, which appears in my installed programs list but I couldn’t find it in ldd /usr/bin/

I’ve noticed the control text that comes with Debian files contains a list of dependencies, so I’m guessing I would be able to run the software if I was to install all of these in most cases? The problem now comes from me being a Linux noob and not knowing how to install packages if I can’t find them by searching the package manager.

1 Like

Never mind, I guess you have to run:

sudo swupd bundle-add devpkg-tiff

For codelite.

How have you installed Presonus Studio One?

I ran this command and installed tiff (it says it’s installed now when I search for it) but I still get this error “libtiff.so.5 => not found” when searching for the Codelite dependencies.

Not working yet.

For installing Studio One I unzipped the debian package and copied the folders into their respective locations (/usr and /opt directories). It shows up in my programs list but I think will need some dependencies to work if at all.

The closest I can find to checking the app dependencies is here which gives me this:

ldd /usr/share/applications/com.presonus.studioapp.desktop
ldd: warning: you do not have execution permission for `/usr/share/applications/com.presonus.studioapp.desktop’
not a dynamic executable

When I have a little time, I’m going to help you.