Headless with Nvidia drivers installed doesn't boot

I followed GitHub - marioroy/nvidia-driver-on-clear-linux: NVIDIA driver installation on Clear Linux to install Nvidia drivers on a LTS kernel. Using attached monitor all works great. Once I unplug it the system doesn’t boot anymore (can’t ssh into it, black screen if I connect the monitor again).
I’ve tried adding nomodset text to /etc/kernel/cmdline.d/my_headless.conf but it doesn’t work. Any suggestions how to setup a headless server for ML on GPUs?


I’m not sure if any of the following may be helpful. In addition to nomodeset, have you tried disabling the GDM service? You may try removing the following file.


Or strip out the following from the file.


Run sudo clr-boot-manager update afterwards. Disabling the GDM service is probably what you need.

Another thing you may try is switching back to multi-user target after the NVIDIA driver installation.

sudo systemctl isolate multi-user.target

There is a knowledge base, but written for Ubuntu.

The next one provides a clue (e.g. “AllowEmptyInitialConfiguration”) in the xorg.conf file.

Finally, tips and tricks - useful information. One can store the display EDID somewhere.


1 Like

Thanks for the long answer! Sadly non of it worked. Think I invested too much time already and will just migrate to Manjaro and use Clear Linux in containers :).

1 Like