How change default boot system

Installed ClearLinux after Windows 11. Found ClearLinux not loading on its own. Solved the problem using the “Dual-boot Clear Linux* OS and Windows* 10 OS” documentation, method 2. I ran the following commands:

1: sudo mkdir /mnt/windows-efi
2: sudo mkdir /mnt/clearlinux
3: sudo mount /dev/sda2 /mnt/windows-efi
4: sudo mount /dev/sda7 /mnt/clearlinux
5: sudo mount /dev/sda5 /mnt/clearlinux/boot
6: sudo cp -r /mnt/windows-efi/EFI/Microsoft/ /mnt/clearlinux/boot/EFI/
7: sudo bootctl install --esp-path=/mnt/clearlinux/boot
8: sudo clr-boot-manager set-timeout 20 --path=/mnt/clearlinux
9: sudo umount /mnt/windows-efi /mnt/clearlinux/boot /mnt/clearlinux

Systems - Linux/Windows have been defined. Everything worked great! I can’t figure out how to change the default OS. Please provide an example of how I can now change the default system. Or which of the above commands to change to make Windows the default (while maintaining the timeout), so it will probably be easier for everyone.

UEFI boot order in BIOS? :slight_smile:

Won’t fit. In bios, I can only select the order of bootloaders, there is no timeout.It would be desirable with preservation of a timeout. Corrected the main question

This worked for me.

First mount the /mnt/clearlinux & /mnt/clearlinux/boot then add two conf files …

You can just make your own windows entry for systemd-boot instead of using the auto generated one.

Make a new entry.

For example /boot/loader/entries/windows.conf

The content of this entry should be as follows.

Beginning of file
title Windows Boot Manager

efi \EFI\Microsoft\Boot\Bootmgfw.efi

End of file
Now edit your /boot/loader/loader.conf file with the following content.

Beginning of file
timeout 15

default windows

End of file
The default property in the loader.conf file should be set to the name of the conf file you made for Windows in the entries folder. The timeout should be set to the amount of seconds you want the bootloader to wait before it goes to the default entry.

1 Like

Just press ‘d’ in boot menu!

Thank you for help! .