How to recover grub after installing Clear Linux OS?

In my workstation, I had window 10 and Ubuntu 18.04. To install Clear Linux OS I deleted ubuntu partition in clear Linux live session and installed in the same partition. After successful installation, the boot loader is going to grub and not loading any os. Please help me rescue bootloader.

1 Like

Clear Linux OS doesn’t use grub, so it will be a remnant of your Ubuntu install. You will need to go to your UEFI settings to select the boot device as the newly installed boot loader.

Installation doesn’t remove boot loaders as it is impossible to tell which ones are still wanted it not and UEFI supports multiple boot loaders, in fact you should probably have one boot loader per OS installed.

without grub How can I install both os?
Do I have to change my UEFI settings every time I boot?

without grub How can I install both os?
Do I have to change my UEFI settings every time I boot?

You need to add a systemd-boot config entry.

  1. mount your boot partition on CL with sudo systemctl start boot.mount
  2. create a file called ubuntu.conf with the following content
title Ubuntu
efi /EFI/ubuntu/shimx64.efi

  1. copy that file to /boot/loader/entries with sudo cp /path/to/ubuntu.conf /boot/loader/entries
  2. add timeout to boot menu, let’s say 10 seconds with sudo clr-boot-manager set-timeout 10
  3. update the boot entries with sudo clr-boot-manager update
  4. reboot.

The same is possible for fedora:

$ cat fedora.conf 
title Fedora
efi /EFI/fedora/shimx64.efi

I have a platform with Clear Linux, Fedora, and Ubuntu :wink:

4 Likes

Thanks for the suggestion,
But the issue I have is I had ububtu (I dont need it now) I had windows 10 (I need it), I installed Clear Linux (removing Ubuntu) , then installed windows 10, followed “Multi-boot Clear Linux* OS with other operating systems”, But there is no OS selection screen even after recovering efi in clear Linux live disk.
Do I have to go to uefi setting every time to switch to windows? is there any solution like you mentioned for Ubuntu?

1 Like

Add the timeout, and you should see the windows entry.

Sorry I am confused. Addtime out where? in windows boot settings? or in clear Linux settings? system directly boots into clear linux now.
Can you help me with the command?

Thanks a lot.

  1. add timeout to boot menu, let’s say 10 seconds with sudo clr-boot-manager set-timeout 10
2 Likes

And

  1. update the boot entries with sudo clr-boot-manager update
1 Like

Wow.
Thanks a lot setting timeout and updating worked perfectly, now I have multi boot option. I guess adding this solution in “Multi-boot Clear Linux* OS with other operating systems" would be helpful.

Thanks again. :smiley:

Tagging @bun.k.tan

Step 16 of “Multi-boot Clear Linux* OS with other operating systems” does say to add a timeout. :slight_smile:

2 Likes

Then what does it use? How does it work? Just curious.

Clear Linux uses systemd-boot.

1 Like

after reading initial steps I directly navigated to " Detailed procedures" section > “Install Windows*” and was stuck in the detailed procedure section what to do next. The issue is resolved now. Thanks