How to get sndio working on clear linux .I need to to run yuzu emulator

Iam trying run an emulator called yuzu .it requires sndio .clear linux bundles doesn’t provide it.i tried to install using make .but I can’t find it in use/lib/ folder .can anyone help me out

We don’t have it in a bundle. I suggest compiling it from source, since it’s small and easy to compile.

Yes I compiled. but can’t find it under /usr/lib . other distros have it there.i need to symlink this way sudo ln -T /usr/lib/ /usr/lib/ .if only then the yuzu application works

You should probably install it under /usr/local and create the necessary file so that ldconfig can pick up the library in /usr/local/lib or /usr/local/lib64.

BTW that symlink might not work.

Just installed it under usr/local but it says failed to create hard link file exists and application gives error.i don’t know why it isn’t working can you help.

man ldconfig explains.

Man 1dconfig doesn’t work. I followed build instructions from sndio completely .my application still says error while loading shared libraries libsndio.6.1 cannot open shared object no such file or directory.
In other distros I just need to run this command
sudo ln -T /usr/lib/ /usr/lib/ it works. I also tried copying those files to usr/lib and create a symlink but still doesn’t work.

I didn’t type 1dconfig, I typed ldconfig.

Yeah I issued that ldconfig but still.same error. isn’t created in /etc/I’

Issue solved when building application with sndio flag off and preloading it . anyways thanks for your support