How To Set Up Clear Linux As Server; But Have GUI Remote Capablity

How can you set up Clear Linux as server (multi-target access), but have remote access with VNC or some other approach that works?

I have installed the Latest Clear Linux Build in VMware as a server but would like to access the VMware host with VNC with a working GUI desktop. It’s not working the vnc session started is bombing out with a “oops” message or the vnc client shows a black screen".
When I start VMware in a multi-target screen I see an error message “piix4_smbus Host Controller not enabled!”

I was able to get a vnc session working that I could contact while the Clear Linux server
install was running in VMware Workstation 16.2.
The alias I created for starting the vnc server is:
alias vnc51=‘vncserver :51 -name $(hostname) -depth 32 -geometry 1905x1000’

Below is how I modified the stock xstartup script in the .vnc subdirectory.
gnome-session seem to fire up as expected.
xstartup script shown below

OS=uname -s
if [ $OS = ‘Linux’ ]; then
if [ -e /etc/SuSE-release ]; then
export PATH
#if [ -x /etc/X11/xinit/xinitrc ]; then
# exec /etc/X11/xinit/xinitrc
#elif [ -x /usr/share/defaults/xinit/xinitrc ]; then
# exec /usr/share/defaults/xinit/xinitrc
#if [ -f /etc/X11/xinit/xinitrc ]; then
# exec sh /etc/X11/xinit/xinitrc
#elif [ -f /usr/share/defaults/xinit/xinitrc ]; then
# exec sh /usr/share/defaults/xinit/xinitrc

#if [ -x /usr/bin/startxfce4 ] ; then
# exec startxfce4
if [ -x /usr/sbin/gnome-session ] ; then
exec /usr/sbin/gnome-session

#[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
#xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title “$VNCDESKTOP Desktop” &
#twm &

Do you know what you changed to get rid of the ‘Oops’ message?

I am not really sure I made some edits to the VMware configuration file: Clear_Linux-OS.vmx,
based on another posting here to add the following:

#For X11 issues:
mks.enableMTLRenderer = “0”
mks.enableGLRenderer = “1” = “TRUE”
#For mouse grabbing/ungrabbing add these lines:
mouse.vusb.enable = “TRUE”
mouse.vusb.useBasicMouse = “FALSE
usb:0.present = “TRUE”
usb:0.deviceType = “hid”
usb:0.port = “0”
usb:0.parent = “-1”

And/or I was able to get the vnc xstartup modified to focus primarily on starting gonme-session.

To be clear the VMware Clear Linux Host does not come up with a login GUI, even though I set
“systemctl set-default”. So this means editing anything in the VMware host environment involved using vi. So this means starting up the VMware host login, start the vnc server as root, then I was able to login to the Clear Linux gnome-session using a vnc client.
I really needed a GUI because I needed to use Wireshark which has an intense graphical user interface.