Must use ctrl-alt to free mouse from vmware console?

Hi, all just taking Clear Linux for a spin. I use ESX and the VMRC mostly for remote desktop. Once I get open-vm-tools installed, then I can resize the screen with a mouse drag, use clipboard, etc. One thing I noticed right away with Clear, is that I have to use ctrl-alt to free the mouse from the vmrc console window. Normally this is no longer required once the tools are installed. Also, the mouse feels kind of laggy.

Anyone have any suggestions?

Thank you

The mouse capture problem sounds very similar to this reported issue: https://github.com/clearlinux/distribution/issues/1203.

I haven’t had a chance to replicate that environment yet. Can you confirm that you have the os-cloudguest-vmware-gui bundle installed?

Thank you for super fast reply!

Yes, I do have the vmware-gui bundle installed.

Also, can I ask you a couple other quick questions?

The tab title in the default terminal is way too big and does not change based on ssh host or directory. Can I easily change that with the native terminal? Does Deepin or maybe even Oh My ZSH play well with CL?

Do you know how I would add dns search domains? Normally I edit /etc/systemd/resolved.conf but that is just an empty file on my CL install. I didn’t see where I could add it in the system settings, network, either.

Thank you!

I don’t know about this and hope someone else can answer better. Deepin isn’t packaged yet. We do have zsh so give that a try.

I don’t recall if the vmware image is using networkd or NetworkManager to configure network. Can you check?
https://docs.01.org/clearlinux/latest/guides/network/assign-static-ip.html#identify-which-program-is-managing-the-interface

I used the .iso to install rather than the vmdk. I find converting vmdk to esx usable is a pain.

Hopefully this is the output you were looking for:

nmcli device status
DEVICE TYPE STATE CONNECTION
ens160 ethernet connected Wired connection 1
cscotun0 tun connected cscotun0
lo loopback unmanaged –
!networkctl list
WARNING: systemd-networkd is not running, output will be incomplete.

IDX LINK TYPE OPERATIONAL SETUP
1 lo loopback n/a unmanaged
2 ens160 ether n/a unmanaged
5 cscotun0 none n/a unmanaged

3 links listed.

Sorry, I forgot NetworkManager is using systemd-resolved anyways. You were right to create /etc/systemd/resolved.conf or /etc/systemd/resolved.conf.d/*.conf. It doesn’t exist by default because of Clear Linux’s stateless design. Just follow the resolv.conf syntax and it will work (i.e.

[Resolve]
Domains=

and systemctl restart systemd-resolved afterwards

Thank you, I will do that.

Do you know if NoMachine is an option with CL? I setup vnc, and can make a connection, but the screen is black and I have no input.

Sorry for all the questions. I don’t know what is the better option. Cram them into one thread, or create multiple threads for what are likely to be simple and fast questions.

Hm, I haven’t tried NoMachine on Clear Linux. I’d say give it a shot and report back if/where you get stuck.
I remember TeamViewer is missing a dependency.

No problem, the community is here to serve our users. Just use your judgement. We can always split or merge topics that get too lengthy or offtopic afterwards.

I’d love to install NoMachine, but I can’t get it installed. Should I download the rpm, deb or tar ?

Try the tar first so that you can try to isolate the installation out of /usr as much as possible.

It looks like the installer does force you to picking from a list of operating systems. I chose “redhat” but haven’t validated if it works.

sudo tar zxvf nomachine_6.8.1_1_x86_64.tar.gz
sudo NX_INSTALL_PREFIX=/opt NX/nxserver --install redhat

Okay, back to your original issue - I had a chance to brush off my ESXi setup and test some things.

I found some of the notes in the ArchWiki regarding Linux guests on VMware to be very true and helpful.
In particular, this one: 3D acceleration and this one and this one Mouse problems.

Here are some things for you to try:

  1. Edit the VM settings to give the VM some more total video memory and 3D video memory. The default on mine was 64MB. Bumping these value up helped reduce graphics lag a ton. Or, using Wayland. Or outright disabling 3D acceleration helped if you don’t plan on using it.

  2. Adding these VM settings to the VMX file (“Advanced Configuration” in ESXi) got the automatic mouse grabbing/ungrabbing working for me and increased the accuracy of host mouse vs guest mouse position:

    mouse.vusb.enable = "TRUE"
    mouse.vusb.useBasicMouse = "FALSE"
    

If these suggestions help you, we can consider adding them to our documentation too.

Another approach for the mouse issue, and maybe a better one, might be if we packaged xf86-input-vmmouse driver - though it does look like it hasn’t had any update in a while:

enabled the module that has since been upstreame’d into the Linux kernel

CONFIG_MOUSE_PS2_VMMOUSE is not set

…
Installing the driver will improve the user experience when using the
mouse to interact with the guest operating system. In particular, use of
the driver improves mouse “lag”, provides mouse speed and acceleration
consistent with the user’s host operating system, and enables the
auto-grab/ungrab feature in VMware products without requiring the VMware
toolbox application.

Heh, sound familiar? :slight_smile:

@miguelinux

Excellent information. Thank you for digging that up. I will have to revisit my Clear Linux VM. I shelved it and moved on to Pop!_OS

I have a bad habit of moving on to a different distro if my current experiment is giving me hassles.

I’m rebuilding a clear vm right now. I will build it with these tweaks in mind and update this thread later.

New clear vm is up and running. Currently I do not have 3D acceleration enabled as I have no plans on using it. This is a Dell R70 with no gpu installed anyway. I did increase the 2D memory to the max of 128MB

I have added the two lines mentioned to the config parameters for this vm in esx.

I have installed the os-cloudguest…vm tools. I have rebooted.

mouse.vusb.enable TRUE
mouse.vusb.useBasicMouse FALSE

No difference. Mouse feels jerky and it gets trapped inside the vmrc until I hit ctrl-tab to free it.

@dmaker Clear Linux version 31330+ has the vmmouse module builtin to the kernel now. Try updating Clear Linux and rebooting.

I created a new VM and the vmmouse driver was automatically used, allowing the mouse grabbing to work out of the box in both the installer and after install.

1 Like