I need help, don’t know what else to do anymore

Hello hope all is well,

I’ve been trying to install CL for 2 weeks with absolutely no success. I’ve tried different ISO’s, the live desktop, live server and even the Virtual Box VM. ABSOLUTELY NO SUCCESS WITH EITHER ONE!

I cannot give up on this because it’s for a university group project so I have to complete this whether I like it or not. But so far this has been an extremely unfriendly experience, also because I’m still a huge Linux noob.

I’m going to list almost every problem I remember encountering these past 2 weeks

  1. The VM never ended up installing, I can’t even remember why but all I know is that I completely gave up on it the first few hours, I also had read that installing it on VM is a huge pain and it wasn’t even gonna work properly so I decided to leave it at that. Whatever, fine. I’ll just use a USB

  2. First USB attempt: The kernel could not boot the usb, FATAL FAIL: “Could not find the installer media.” It scared the crap out of me at first but I decided to do my research. I tried searching for a solution but to no avail. So I asked myself, “This USB is pretty old, maybe I should go get a brand new one” So I did exactly that. After flashing, and going through the same process… IT WORKED. I was boasting with happiness, but of course it doesn’t end there.

While trying to choose a disk to install the OS into, the only available disk was my primary disk. I said what the hell? I only want to live boot this! So I did my research again. This time I wanted to test something out, I went back to Windows and unallocated 20 gb out of my main disk, maybe this will work…?

Went back and did the same process… blah blah blah. I decided to use Advanced Partitioning, and everything was going so well……….UNTIL THE BUNDLES HAD TO INSTALL


Okay okay, let me just try again.

I looked up the issue and somebody said this had been happening with some releases, so I decided to install a different version.

I couldn’t do it for a couple days because the download links were down, I had to wait it out for a couple days to see if someone would mention anything about it anddd eventually somebody did. Thank God.

I know, I should’ve asked myself but I trying to avoid the hassle of creating an account.

Anyways, somebody replied with the list of releases. (and yes I eventually ended up noticing this link was on the website so that’s completely my fault)

I went to find some random release, flashed it and you already know the rest, It didn’t work. This time it was something about the ISO being corrupted.

I took a break for a while after this because I was tired of it already.

My teammate had said they used another usb drive as the installation disk. So I did exactly that. But this time I decided to use an older ISO from late-ish December.

Same flashing, same process but this time I used Destructive Install because the second USB showed up as a disk. I was finally seeing a glimmer of hope but kept my expectations extremely low anyways.

The installation took a long time, I genuinely don’t know how folks get to download it in less than an hour but everything was going great so far. Very slow, but great.

I decided to go to sleep and leave it alone for some hours. I slept like dookie so I ended up waking at about 3:00am. I turned on the computer and LO AND BEHOLD! Verifying installation files.

It was like seeing Jesus in the flesh. I went and looked around to make sure everything was going fine. I found it weird how the bar kept bouncing from left to right for a while but didn’t think anything about it. Until I saw that my wifi wasn’t connected anymore…

I immediately clicked on settings and it said “Unable to find wifi adapter.” I died.

I went to get my wireless USB adapter but had no way of connecting it because NONE of the apps were working. Not firefox, not the advanced networking app, Bluetooth didn’t want to turn on and not even the TERMINAL was working. Every time I tried opening an app a loading wheel would appear then disappear after 15 seconds as if I didn’t click on anything whatsoever.

I couldn’t do anything, the installing base OS section had a yellow X on it. I realized I was screwed for the 74664th time.

Disappointed, I ended up turning off the computer and going back to Windows to repeat the same process.

When I booted the USB the kernel said the installation media had failed, back to square one…

It’s currently 5:42 am and I’ve been trying to fix it, I went and flashed the USB drive with the same ISO but the same error happened, I’m starting to think I might’ve corrupted the usb.

I’m downloading another release version to see what happens from there. Feeling bummed out since that was the closest I ever got to installing CL:/

Thanks for reading my rant. If you’d like to offer some advice it would be greatly appreciated, I have to turn this work in very soon so if nothing ends up working I’ll just have to find a different solution.

If anyone knows a release version that works properly that would be awesome

  • When flashing the USB drive, use a tool like Rufus or Etcher to ensure the process is done correctly.

  • If you encounter issues with wifi adapter detection, try using a wired connection during the installation process.

  • Make sure your Virtual Box settings are optimized for running Clear Linux.

regard to install to Virtual Box VM, did you read the guide below? This is the official one.

To make a bootable USB media, there is the other official guide as

Yes! I read everything, including the VM one. It never ended up working correctly but I’ll try again just in case

I’ve used both Etcher and Rufus, same issue

I’ll definitely use a wired connection next time,
I will also try to boot using VM again just in case.


1 Like