Java questions. Java on Firefox

I installed Java (it seems to have been installed anyway), (although I can’t find it through programs?) Via “tar zxvf jre-8u251-linux-x64.tar.gz”. The purpose of this was to use the Ancestris program. Which apparently runs in the browser. The following is associated with the installation of Java: “After installing Java, you will need to enable Java in your browser.” When I tried to do this in Firefox, I came across the information that Java is no longer supported by Firefox. So how do you proceed now? Firstly, I now have Java installed, which cannot be uninstalled? Any other browser that might support Java may not be able to install under Clear Linux? Should I have Java installed for security reasons? Mention that I have Gramps installed, which works. The purpose of installing Ancestris, was to test it as it seems to have little features other than Gramps.

I’ve no experience with this software before.
Have you successfully installed it?
The official step-by-step guide is available here:
https://en.ancestris.org/index.php?title=Installation_on_Linux

Another question, it doesn’t mention anything related to Firefox or other browsers. Why do you need Java support in browser?

“You should always check Clear Linux first.”
https://clearlinux.org/software/bundle/java-runtime
https://clearlinux.org/software/bundle/java-basic

So then Java should be installed now anyway.
Which nevertheless did not change anything. Ancestris did not start when I followed the following instructions:

Then click on ‘ancestris / bin / ancestris’ to launch Ancestris.
The Welcome screens then appears. You are now ready to use Ancestris.
https://en.ancestris.org/index.php?title=Installation_on_Linux

I “installed”, Install the Ancestris daily version
So unpacked the folder, and followed the above instructions.

The Ancestris file opens in the text editor. Have tried to open it via other programs without successfully starting the program.
So maybe this is just about finding the right program?

About enabling Java in the browser.
I read the following at https://clearlinux.org/software/bundle/java-runtime
“After installing Java, you will need to enable Java in your browser.”
I probably misunderstood this, and do not need to do this?

It turns out you don’t even need to follow that step-by-step guide.

Navigate to the /ancestris/bin directory in shell, run
. ./ancestrix

Which I have done, and described above.
When you read the file’s properties, the following is displayed.

characteristics
basic: shell script (application / x-shell script)
run: allow to run the file as a program
open with: standard program; text editor

the first line of the text editor shows: #! / bin / sh

So you should change the default program from text editor to ???

You can add a desktop file yourself, or launch it in shell.
I can launch it normally and I haven’t done anything to the browser.

May I please ask you to open properties and look for what program opens with: standard program; (in my case incorrectly, “text editor”)

I think this is the expected behavior.

Ok, thanks.
And now what am I supposed to do???
Clearly I’m not familiar how to use such software, or Linux as a newbee

Download the “LINUX > Generic file ZIP”. After that, open a Terminal.

Install Java:

sudo swupd bundle-add java-basic

Change directory to “Downloads” in your home directory (should be the default where Firefox stores your downloads):

cd ~/Downloads

Extract the downloaded archive:

unzip ancestris_10-20200208.zip

Change directory to the binary directory of the extracted files:

cd ancestris/bin

Run Ancestris:

./ancestris
1 Like

Thank you so very much for your outstanding response. It is greatly appreciated. With this I saved a lot of time and anxiety.
It works now, and turned out to be a much better program than Gramps at a quick glance. At least in my opinion.

I think genealogy is very interesting. For in Sweden, all the inhabitants are registered since around the 17th century. So without being from a noble family, (there are, however, many nobles and kings in my family), you can in most cases find their early relatives. There are very interesting life destinies to take part in. An interesting thing in these times is to look at the population, which was 400,000 around the 11th century to rise to 1,100,000 around the 13th century. Then Sweden suffered a pandemic / plague (the black death) and the population fell to 347,000 in 1413. It must have been a terrible time to live in then. What we are experiencing now is nothing in comparison.

Was thinking about whether it is possible to create an icon to start from, which I have previously done for some programs. For example, Scrivener, Icedrive, and Realtime Sync.

I follow the instructions in the following site for this.

: //www.maketecheasier.com/create-desktop-file-linux/

[Desktop Entry]
The encoding = UTF-8
Version = 1.0
Type = application
Terminal = false
Exec = / home / computer name / Downloads / Icedrive \ Portable / Icedrive
Name = Icedrive
Icon = / home / computer name / Downloads / Icedrive \ Portable / Icedrive.png

I would create a directory for applications like /home/<USER>/bin or /home/<USER>/applications, so you have a dedicated directory for such appliactions and don’t have them scattered around under Downloads or other paths.

Just assume you have the directory /home/<USER>/bin created and put the extracted ancestris directory there.

You can create a ancestris.desktop file in /home/<USER>/.local/share/applications with the following content (you need to adjust the <USER> and maybe the paths):

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Terminal=false
Exec=/home/<USER>/bin/ancestris/bin/ancestris
Path=/home/<USER>/bin/ancestris/bin
Icon=/home/<USER>/bin/ancestris/bin/ancestris.ico
Name=Ancestris
Categories=Education;
Comment=Genealogy Software

After the file is created, there should be a icon to start the application in your applications menu. If you use the default Gnome desktop, the start icon should be there immediately. If you use another desktop environment, you may have to restart something to make it visible.

2 Likes

Thanks again for your helpfulness with clear and clearly detailed advice. I also hope that someone else can be helped by them. I followed your advice and created a special folder for programs like ancestris and others. I will also move over the other programs there. Should have done this right away, but now so …
ancestris.desktop file is created and working. Got to scale down an image in resolution 58x58 pixels.