Install .deb file

Hey I have been using linux for a little while but still a beginner. I am trying this distro out and I am really enjoying using it. One thing though, I want to install a piece of software called Maptool located here https://www.rptools.net/download-rptools-products/. Just wondering how i would go about installing this as I was able to just install by running the file in ubuntu based distros. Thankyou very much in advance.

Since these software manufacturers offer a jar file, I would download that and run it with Java:

$ java -jar MapTool-1.5.2.jar

deb files are not supported by Clear Linux, sorry. There’s some tricks you can do but in general packages for other OS’s don’t work out of the box.

Fantastic, thankyou for your help.

im getting an error when trying to run the java file:

java -jar /home/mikejames/Documents/MapTool-1.5.2.jar
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: net/rptools/maptool/client/LaunchInstructions has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)

assume that I need a later version of Java. Just dont know the correct way to do that. Ive installed java from the store.

I actually tried myself with sudo swupd bundle-add java11-basic and then java11 -jar ... but it still does not run - I get log4j errors amongst others. Perhaps our Java folks can look at it. Sorry.

can i convert the .deb package into one that clear linux will be able to use?

Note for Users Downloading the JAR

This version of MapTool requires JavaFX which means you must have Java 9 or 10. The current version of Java 11 from Oracle or the OpenJDK will not work because the JavaFX library isn’t included. If you have enough development background, you may be able to puzzle this out but we are only supporting Java 10 at this point.

i tried to use the java9-basic package but it just came back with this:
bash: /usr/bin/java: No such file or directory

looks like i need java 10 to run it, doesnt look like i can install this from the software center. anyway i can install this manually?

The binary will be called java9.