Lost my theme on gnome

Was materia with paper icons. Suddenly it’s gone and I’m stuck with adwaita, and gnome tweaks can’t seem to find or recognize any installed themes? Very strange, I really enjoyed the materia theme, and until now clear linux with gnome on wayland has been the best – better than mac or ubuntu – desktop I’ve used for dev and admin work.

I’ve never signed up or had to posts anything before, because everything just works so amazingly well, especially for such a young distro. If there isn’t a bundle for what I need I just download a tarball and throw it in /opt. How hard can it be? Compiling, archiving, building and installing have become so quick and easy I store nothing locally anymore and pull from git in the morning and push and delete in the evening. My workspace is so clean I can never go back.

But why are my theme configurations gone and dead? Why was my dash to dock uninstalled? It’s not just wayland either.

5 Likes

+1, I reported the same issue here:


Although I was already using dash-to-panel over dash-to-dock, so while I noticed that change, I wasn’t affected by it.

sounds like a bug :frowning: . Can you open an issues on the GitHub tracker with any additional detail you may have?

@mesiment any ideas?

Same for me after updating to 32360. Open Closed bug: https://github.com/clearlinux/distribution/issues/1766

EDIT: Solution

1 Like

Same issue. All themes and icon themes are gone.

The files are still there in ~/.local/share/icons

Are they? I have only the app icon for Joplin left:

$ ls -1aR ~/.local/share/icons/
/home/me/.local/share/icons/:
.
..
hicolor

/home/me/.local/share/icons/hicolor:
.
..
512x512

/home/me/.local/share/icons/hicolor/512x512:
.
..
apps

/home/me/.local/share/icons/hicolor/512x512/apps:
.
..
joplin.png

Solution from GitHub:
sudo swupd bundle-add desktop-assets-extras
That work for me.

5 Likes

Sorry all, this was my mistake. In general we don’t want to impact users of existing content with bundle manipulation changes and got this one wrong. The goal here was to make new installs be a vanilla gnome experience without making users of the existing themes notice a difference.

4 Likes

would this also have affected taskbar settings? mine got moved from the bottom to the left side after a recent reboot.

After updating to native-5.6.8-944 the same problem came back, but worse.
No icon, no theme and NO PATH in terminal (right click - open in terminal => PATH freeze at ~/user).
the bundle desktop-assets-extras is already installed.
How could I recover everything?
Thanks for your time

2 Likes

I also thought this was a bug at first, but it is part of the update. The only way to get the themes back is to reinstall them manually.

May I ask why the terminal freezes at /home/myName wherever in the tree since the recent update? Is it a bug or something else?
I spent a lot of times on the internet, but nothing really helpfull.

I didn’t observe this behavior. Have you modified your shell profiles?

No. I was working on my project.
the update came and the terminal is freezing.

Does reboot fix this?

I tried 5 times. Still the same.
I looking for an explanation. It’s really weird.
months ago, I installed clearlinux on another machine not connected to the internet.
So, no automatic update. I compared the profile file at /usr/share/defaults/etc/ but nothing really interesting.

I assume you use bash and you didn’t modify ~/.bashrc right?

Yes. Exactly.
.bashrc is still the same.

I have 2 sessions. The terminal has the same behavior since the update.
Right click somewhere to open in a terminal and the path is missing.
I’m still in /home/Myname