NUC7i7DNHE compatible internal SATA SSD disk - fails to recognize

I run CL on an NUC7i7DNHE.
It has 1.9TB M.2 .
To add to it, I initially purchased a 2.5 SATA SSD Seagate 860 Pro 1TB disk.
It wasn’t recognized.
( lsblk doesn’t show it )
However, it’s also not on the compatibility list.

Going to that list, at
I chose a Kingston SUV500/480GB disk.
It’s failed too.
‘dmesg’ says ‘ata1: SATA link down(SStatus 4 SControl 300)’

BIOs is up to date (DNKBLi7v.86A.0067.2019.1101.1743).
System already has an M.2 disk (1.9TB).
It should also support a SATA disk, so said some docs.

Is there something I’m missing?

My intent is to put Windows on the new disk.
Thanks for any help.

Does the disk show in BIOS? Is that the last reference to the disk/controller in the dmesg output?

How does a disk show in BIOS? In the boot order is just “Linux bootloader” and network options. Neither the NVME disk nor any other disk are explicitly mentioned there. ‘nvme’ does appear in dmesg and in lsblk.

Can you (use a pastebin) post the full output of sudo dmesg perhaps, when booting clearlinux with the unrecognized drive connected? Bonus points if you can do the same with a Linux version that works with that drive - then we should be able to iron out the problem quicker.

Pastebin (good idea, thanks!):

No bonus points for now, alas.

dmesg from Clear Linux version 32300,
uname Linux keller 5.5.2-903.native #1 SMP

That’s indeed not enough for bonus points. Nothing unfortunately from that dmesg that is helpful - if you do have the time to boot a Linux that recognizes the drive, it would be instrumental.

Debian linux live (debian-live-10.3.0) wouldn’t load (“junk in compressed archive”) but its installer loaded enough for me to look at its dmesg – still no disk recognized. NUC7i7DN tech specs says Windows has AHCI drivers. Does Clear Linux have specific AHCI SATA drivers? I’ll inquire with the vendor I purchased the NUC from now.

I’ve booted clearlinux on a NUC7i7DNK without issues a while back. AHCI is a standard maintained by Intel. If the BIOS is in AHCI mode and you didn’t setup any RAID stuff in the BIOS, then AHCI mode connected SATA drives should just work without issue.

If this drive isn’t recognized at all in several other OS’s then I suspect a drive failure, or just a drive that is fundamentally incompatible with Linux at all. The only other possibility is inadequate power to the SATA drive, but that’s highly unlikely.