Clear linux isn't installing on nvme [solved]

I tried install clear linux to server with xeon e5 2666v3, 32gb ddr4 and nvme “KingSpec” 512gb. If I choose destructive installation — it fails on “writing ext4 file system to nvmeOn1p2”. In advance installation it fails on “rescanning media”. I tried to install windows server, it was installed successfull. It means that my nvme is working. How I can fix it?

1 Like

Will Clear perform a non destructive install alongside Windows?

I tried all types of installing very many times. Safe, destructing and advance. In advance I created two partitions(CLR_BOOT, CLR_ROOT), and clear linux recognized it and started installation. I also tried create this partitions in gparted live image. In this attempt it almost installed, but it gave an error that it couldn’t create the bootloader. I tried this again, but i take error "getPartitionTable() had an error reading partition table “Error: /dev/loop0: unrecognised disk label”
I think loop0 is the live OS. I also tried install centos, and it had the same error. But windows normally installing! I don’t understand why it happens…

What kind of mother board do you have? Does it hame AMI bios? Maybe a setting that affects how it
is booted.
I ask this because I have a system has AMD Processor. The mother board is a:
MB: ASUS ROG STRIX B550-F GAMING
AMD Processor: AMD Ryzen 9 5950X - Ryzen 9 5000
M.2 SSD (NVMe): Western Digital WD Blue SN570 NVMe M.2 2280 1TB PCI-Express 3.0 x4
RAM DDR4: 32 GB

Anyway this system was able to have Clear Linux installed after booting using the iso
clear-36010-live-desktop.iso written to a DVD.

You could also try to look at the NVMe drive partition table using the Clear Linux shell to see if the look as expected after temporarily mounting it. Maybe the NVMe drive needs to be set up in a way that only windows supports.

You might try to install Clear Linux on some other drive that is not the NVMe as a test this would help
in narrowing down where the issue is.

Motherboard is Huananzhi x99 BD4, and it has AMI bios. I tried many of bios settings, but no one help me to install clearlinux. With different settings installation gived different errors, it was:
“fsyns Intup/output error”
“Unrecognized disk name: loop0” (it was before mounting partitions, and installation finishes after “mounting /” the ext4 root partition, but it didn’t gives some errors in this moment)
“/dev/nvme0n1: no such file or directory”

But I feel it is some of bios settings! Windows installs succesfully, it means all components is working, and problem in the linux. I tried to install centos/centos stream, ubuntu/ubuntu server, debian, arch. All it fails on writing nvme.

I found bios settings for sata disks, but I didn’t found any settings for nvme.

Please, someone, give me solving of this problem. I tried variety of attemts, but I couldn’t install any linux. Why windows is installing normally? I need to install currently linux, not windows. May it solve by some commands in console? I have very small expirience in linux and his installation and can’t solve it. Other solvings in internet didn’t help me

in bios: fast boot and quick boot off, build-in shell on

on starting usb flash: press “e”, add params nvme_core.default_ps_max_latency_us=0 nvme_load=YES

on installation: choose LTS core instead Native

And clearlinux will normally installs on your nvme!

Excellent. This looks like it was a hard one to track down. Did you have to call the mother board vendor? I was lucky in my ASUS AMD motherboard. It just worked.