Need help - dual boot with Win10

Hello I have an issue with dual boot Clear Linux and Win 10. I has a NUC with two SSDs, one with Win10 (NVMe1) and one with Ubuntu (before) NVMe0. Previously it can dual book Ubuntu and Win10 fine with GRUB.

I did a destructive install of Clear Linux on NVMe0 today. The install went well but I can only boot to Clear Linux now. The BIOS F10 Boot page only list NVMe0, and the EFI on NVMe0 only has Linux.

Here is my output of “lsblk -po NAME,SIZE,TYPE,FSTYPE,PARTLABEL”
/dev/nvme1n1 477G disk
├─/dev/nvme1n1p1 16M part Microsoft reserved partition
├─/dev/nvme1n1p2 476.4G part ntfs Basic data partition
└─/dev/nvme1n1p3 526M part ntfs
/dev/nvme0n1 110.3G disk
├─/dev/nvme0n1p1 149M part vfat EFI
└─/dev/nvme0n1p2 110.1G part ext4 /

From the document (, it seems to miss the “100M part vfat EFI system partition” partition on the Win10 drive.

How can I get it back and setup dual boot correctly? Please help. Thanks.

Hmm. I would not have advised “destructive install” of any kind without first removing the NVME where windows resides. You should have either removed the other drive first, or select installation media manually.

Do you have recovery usb media for windows?
If not download it here
Create the Windows media on a usb stick using belenaEtcher

Remove your NVME whith Clear Linux on it from your nuc then attempt to boot or go into bios boot menu and see if you now have any options for windows. If so and windows isn’t booting properly press F8 rapidly when windows first starts to load, ie when you have the little spinning circle of dots on the bottom of your screen, then skip to step 3 below. If not,

  1. Insert the usb stick you made with belenaEtcher and restart .
  2. Boot from the media.
  3. Select Repair Your Computer .
  4. Select Troubleshoot .
  5. Select Advanced Options .
  6. Choose Command Prompt from the menu:
  • Type and run the command: diskpart
  • Type and run the command: list disk
  • Note the number of your NVME
  • Type and run the command: sel disk <the number of your NVME>
  • Type and run the command: list vol
  1. Verify that the EFI partition (EPS - EFI System Partition) is using the FAT32 file system. Assign a drive letter to it that is not already in use.):
  • Type and run the command: sel vol <number of volume>
  • Type and run the command: assign letter=<drive letter>:
  • Type and run the command: exit
  1. In order to repair the boot record:
  • Type and run the command: cd /d <drive letter>:\EFI\Microsoft\Boot\
  • Type and run the command: bootrec /FixBoot

If you don’t see an efi in ‘list vol

Run the following commands in place of steps 7 -8:

  • create partition efi
  • list partition
  • list vol

Note the volume letter (Ltr) where the Windows OS is installed <Here we will refer to it as “X”>

  • exit
  • bcdboot X:\windows

Where “X” is the the volume letter of the Windows OS partition.

Remove the usb and restart your nuc.

1 Like

Thanks for everyone who helped me. I fixed it after recreating the Win10 EFI partition.

1 Like