[Problem] Bluetooth works for audio but not for File Transfer

Hello everyone, I’m having a problem with Bluetooth file transfers. Bluetooth works fine for audio, I can connect my Bluetooth headset and works like a charm. My problem starts when I connect my phone via bluetooth and I want to send some files to the PC.
The PC basically doesn’t react, I have sucessfully paired both devices, yet for some reason when I try to transfer files, nothing happens, not even a dialog asking to receive the file. My Android phone just says “The file wasn’t sent to BlueZ 5.62, Reason: Connection Unsuccessful” (even if paired).
What’s a bit odd is that my phone thinks of my computer (BlueZ 5.62) as an audio device or something, and when I play audio from my phone, my computer starts playing it in it’s speakers if both are paired and connected, weird.

I tried searching the Clear Linux OS forums but haven’t found people with this kind of issue, I also tried looking in dconf to see if maybe some config there could be changed, tried GNOME Tweaks… Nothing, couldn’t get it to work.
Any help would be appreciated!

PC can be file sender with OBEX profile after Bluetooth paring, but can’t be receiver without extra steps, I suppose.

Did you install gnome-user-share and make it enabled?
https://help.gnome.org/users/gnome-user-share/stable/gnome-user-share.html

Sorry if this is inconsequent response.

1 Like

Thanks for the answer, espio.
Unfortunately I don’t have that much experience with Linux, I tried to search if a bundle for gnome-user-share exists in the Clear Linux Store, but haven’t really found anything, also I tried to use swupd to see if maybe I can download the bundle from there, but it was not possible.

Do you have a step by step on how can I install it? I asked elsewhere and some people said this Bluetooth issue may be a bug with Clear Linux, and that I should report it. I can’t send files to my phone from the PC either.

Thanks in advance!

Do you have a step by step on how can I install it?

Sorry, I don’t.

It seems that no bundles have gnome-user-share at this moment.

I am not sure the reason why you adhere Bluetooth Object Exchange, though exploring other way as network file sharing or exchanging via cloud services will be easier.

I don’t have that much experience with Linux

This is not sarcasm.

If this is true as you need information at step-by-step level, I don’t recommend to use CL.

CL has different manner from other distribution as providing blended packages as bundle and installing at this level, not at single package level. And its information is limited so that it is pretty minor.

If such manner is not fit with the style of user, using CL will be stressful, especially for new users.

Example Ubuntu, you can easily find the way to install gnome-user-share with apt, and immediately do it. But CL is not.

1 Like

Thanks for the answer!

Yeah, I did search the CL Store, and I also used swupd with the command “sudo swupd search”, but had no luck.

The reason on why I want to use Bluetooth for file transfers is just because I was used to it and felt it was easier to me, I’m just starting to migrate from Windows to Linux because I’m tired of Windows’s broken updates, slow performance, instability, virus, etc.

And yes, because of that my experience with Linux is basically zero, but I found CL so far to be a very pleasant OS, everything worked out-of-the-box compared to Windows, where I had to install drivers to basically everything and lots of updates, this doesn’t happen in CL. Most programs I used on Windows are available on CL as well.

You are right that I should switch to a easier distro, right now I’m not having serious issues with CL and most things work pretty well for me, but if I find a big problem that prevents me for using my computer in a meaningful way, then I will just migrate to another distro like you said, like Ubuntu.

For the time being, I will also do what you said and use a network-based file sharing solution, tried using my phone as a FTP server and Nautilus File Manager on the PC to access it, it’s not as straight-forward like Bluetooth where I could just select the stuff I wanted in 2 touches and send it to the PC, but it works and gets the job done.

Thanks for the help, and I hope you get a nice day :+1:

1 Like

first do:

systemctl --user start obex

then try transfer.


--user Connect to user service manager (this may be used so that you dont need root)

start UNIT... Start (activate) one or more units

stop UNIT... Stop (deactivate) one or more units

enable [UNIT...|PATH...] Enable one or more unit files

disable UNIT... Disable one or more unit files


4 Likes

Worked like a charm, now I can receive files! Thanks a lot, also thanks for the links and teach me new stuff, really appreciated!