No MTP device found

Somewhat newish S10 with android 11 connection usb3 to usb-c connector on many different cables won’t connect. Despite my enabling developer mode to force file transfer I can’t get my phone to be open in file manager.

Any ideas? mtp-tools install? Some sort of fuse ability add?
I did see the two posts related to this on CL but unless all my cables are bad that solution doesn’t fix it.

I kind of assume it has to do with the stateless nature but no proof just yet.

Will look at /etc/fuse.conf maybe.

I have a Pixel 2XL with android 11 and a usb3 to usb-c cable. Works for me.
I have the storage-utils bundle installed. Maybe that has something to do with it.
Also, some of these usb cables can only be used for charging. Can you check the cable on some other devices?

Yep. This is important to know. Actually most 3rd party cables are only designed for charging.

This happened about 2 months ago for me after an update. A previously working cable and phone-combination suddenly were unaccessable (also a samsung phone, but an older one).

I discovered that mtp-detect could only identify the phone when it was in charging-only-mode (ie. the exact reverse from the expected).

My solution was to use GitHub - whoozle/android-file-transfer-linux: Android File Transfer for Linux which seems to address the quirk somehow.

1 Like

OK, just to rest the cable deal. The cables work on other linux. :slight_smile:
I’ll try the bundle to see.

Thanks for the ideas. Keep them up. I’ll try this today or tomorrow if work slows down.

I peeked at the mtp source and I didn’t get to checking my phone but I’d assume mtp should work.

I went to /etc/bin for the mtp programs available but in the correct phone setting or not it still reports no devices. I’ll put in the other modes to test again.

Did you have any success?

storage-utils bundle didn’t fix it.

No amount of switching phone usb settings help fix it.

Might go on to the whoozle next.

I looked at a lot of other reports on MTP and tend to think it is a fault in lsusb. Sure folks say other ways to mount fixes it but some permissions come up.

If work ever slows down I’ll maybe fix that on a test.

Marking closed solved for now.

Thanks for the replies.