Why cant I copy any files from android storage connected?

I have connected an android device to my Workstation, I can delete the files in the phone but I can’t copy or move any files inside the phone, I can copy data from phone to PC but not the other way around. I have mtp driver, the phone is unlocked, allowed to transfer files.
Any solution? what is causing the issue?

I usually set my phone to “File Transfer” instead of “MTP”. You can change this in the Android settings. That allows me to delete files.

What is the output of

ls -l /dev/$(readlink /dev/libmtp*)

Could be it is permission issue

This is the output of the command:

crw-rw-r–+ 1 root root 189, 36 Jun 7 11:25 /dev/bus/usb/001/037

Tried that also. Didn’t help.

This is not the proper solution just a workaround, try to change the owner ship of your device.

sudo chown $UID /dev/$(readlink /dev/libmtp*)

we need to find the proper solution.

same error

ls -l /dev/$(readlink /dev/libmtp*)
gave

crw-rw-r–+ 1 prady_workstation root 189, 47 Jun 7 12:30 /dev/bus/usb/001/048

Notice the + in the permission bit. It’ll have acl|attr bits on top of permission bits:

sudo getfacl /dev/$(readlink /dev/libmtp*) should show the acl for this file.