Moto Z play can't connect to CL over USB

I can connect my Moto Z play on Windows and transfer data. On CL I can’t connect (using same cable) - it shows “Turbocharging” but not asking to setup USB mode as “File Transfer” as on Windows. No pop up message. libmtp is installed. It shows USB as not connected. I’ve enabled Developer Mode, using USB in debug mode, changed USB mode from my device - nothing works.

On my Motorola, I have to go into the phone’s USB settings and change the mode to “File Transfer”.

The phone is in control over the mode. I don’t recommend MTP mode, it is somewhat limited.

I agree. But I can’t see “File Transfer” on my moto Settings. On Windows I can see “File Transfer” after windows recognized my moto and vice versa. Only after that I can see a new popup window on my moto with “File Transfer” option. On Linux I can’t get to that point. USB is not connected.

Well you can’t do anything without connecting it first. Maybe I’m misunderstanding here.

Yes, sorry for confusion. With same options on my moto device and the same cable and working USB3 type-C ports - it can connect to Win 10 but can’t on CL. Just curious why.

Does this work on any Linux distro? Or have you only tried Clear Linux OS?

(Note: I’m using USB-C myself with mine).

Only CL and only on one PC (well, also some VM Linuxes under CL host - no succes). In a past I could connect another device (Samsung) to another Linux (Fedora), but it is not relevant now. BTW, I’ve tried USB type-A to type-C - it doesn’t work even on same win10 laptop.

May be I can boot from another Linux on USB stick. What Linux can you reccomend? MX-Linux, Fedora, Manjaro ?

Tried MX Linux and Mint - same results. May be some hardware compatibility issues.

I suppose that you have already tried all combinations, but just maybe try this:

  • unlock the phone -> then connect via usb to the system. This is broscience though.

Also what does mtr-detect show when you connect your phone to CL?

I have bought another cable and it became connected with that cable. Problem solved. Thanks for suggestions.