[Problem] Is x11 gone? Cogwheel has disappeared!

Hi, it has been a time since I used Clear Linux. I noticed that the x11 session has disappeared? I can’t login to x11 anymore. The reason of why I want to use x11 is because there is a Java app that seems to be failing on Wayland, so I wanted to try x11 to see if it works. Thanks in advance!

I believe you have to add a few bundles before the cogwheel can be found
As for me, I have added games-dev so I still have the cogwheel
CL - 40390

Thanks for the answer! So… if I install the games-dev bundle I will gain the ability to switch again to x11 via the cogwheel? I tried installing it, but it’s going painfully, slow (downloading at around 32kbits/s for 4GB). Is there another way to do it?

Update: The package ended up installing after waiting, and I managed to log into X11, thanks!
Just a question, is there a way to do this without that bundle? Is really big (4GB)
Update2: Can confirm my application is working on X11 again.

The bundle name is x11-server.

1 Like

swupd bundle-add os-utils-gui

  • Provides a graphical desktop environment via xfce4

According to swupd is only 181MB but you might can slim it down even more with

swupd bundle-add os-utils-gui --skip-optional

1 Like

I may have a similar issue. I just recently tried to go from:
Statistics for going from version 40030 to version 40410:

changed bundles   : 686
new bundles       : 6
deleted bundles   : 0

changed files     : 324374
new files         : 101868
deleted files     : 69200

Now My gome-desktop GUI does not come up, but the rest of services do. I have an Intel GPU graphic board.
I was able to log into the server with ssh and power down and then revert to the previous
build version.
What do I need to do to restore the GUI console log in back.