qBittorrent 4.4.0 crashes after launch

I’ve just updated Clear Linux to version 35640 and qBittorrent which was installed was updated too from version 4.3.9 to 4.4.0.

It crashes after launching it. It worked perfectly before version 4.4.0

I also tried launching it from the terminal and here’s the output :

$ qbittorrent 
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

Please file a bug report at http://bug.qbittorrent.org and provide the following information:

qBittorrent version: v4.4.0

Caught signal: SIGSEGV
Stack trace:
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0x1c5c80  [0x7f260b627c80]
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0x1ba520  [0x7f260b61c520]
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0x1ba7c0  [0x7f260b61c7c0]
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0x1ba8fd  [0x7f260b61c8fd]
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0x1bb078  [0x7f260b61d078]
  /usr/lib64/libtorrent-rasterbar.so.2.0 : ()+0xfa98f  [0x7f260b55c98f]
  /usr/lib64/libstdc++.so.6 : ()+0xf3154  [0x7f260987d154]
  /usr/lib64/haswell/libc.so.6 : ()+0x9c232  [0x7f26094fe232]
  /usr/lib64/haswell/libc.so.6 : clone()+0x44  [0x7f2609590284]
Segmentation fault (core dumped)


1 Like

I’ve read that. Multiple issues have been opened for this bug. It’s also affecting Windows users.

qBittorrent 4.4.0 works fine in EndeavourOS which is also installed on my laptop.

In the meantime the qBittorrent devs fix this bug I’ll use the Transmission flatpak

1 Like
1 Like

It’s still crashing in version 4.4.1

Someone reported the bug for Clear Linux :

1 Like

qBittorrent was just updated to version 4.4.1-24 and is finally working again in Clear Linux 36030