RFCOMM TTY support not available on Jetson Nano

Hi everyone,

Recently, I tried to read data from external bluetooth sensor to the program in Jetson Nano. I found some tutorials which worked for raspberry Pi 3b+. The procedure is like this: 1)sudo nano /etc/systemd/system/dbus-org.bluez.service; 2)ExecStart=/usr/lib/bluetooth/bluetoothd -C; 3)
ExecStartPost=/usr/bin/sdptool add SP; 4) sudo rfcomm bind 0 00:04:3E:4B:32:40. By these commands, I could successfully read the data to the raspberry pi. However, when I applied them into Jetson Nano (because there is no bluetooth module for jetson nano, I used bluetooth adapter), it could not work. If I edit /etc/systemd/system/dbus-org.bluez.service as I mentioned above, the bluetooth service even fails to start. When I give the command “sudo rfcomm bind 0 00:04:3E:4B:32:40”, the error message was threw which said “RFCOMM TTY support not available”. Is this error caused by my bluetooth adapter or other reasons? Could you provide some suggestions, thank you !

Very difficult to debug. Start with sudo dmesg and read everything carefully. Check with upstream bug reports. Which kernel did you install?

1 Like

Really thankful for your reply. I have been bothered by this issue for very long time. I googled a lot and asked many people for help but still difficult to find the solution.

  1. My kernel info shows as below
    lamb@lamb-desktop:~$ cat /etc/issue
    Ubuntu 18.04.3 LTS \n \l

lamb@lamb-desktop:~$ cat /proc/version
Linux version 4.9.140-tegra (buildbrain@mobile-u64-911) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #1 SMP PREEMPT Tue Jul 16 17:04:49 PDT 2019

lamb@lamb-desktop:~$ uname -a
Linux lamb-desktop 4.9.140-tegra #1 SMP PREEMPT Tue Jul 16 17:04:49 PDT 2019 aarch64 aarch64 aarch64 GNU/Linux

  1. The log info of dmesg shows in this link (https://paste.ee/p/5FQSe), because I am new to linux, could not understand well about the log info.

  2. I may find the reason why the error message shows “RFCOMM TTY support not available”. But I don’t know how to solve it. Please check below.
    lamb@lamb-desktop:~$ zcat /proc/config.gz | grep RFCOMM
    CONFIG_BT_RFCOMM=y

CONFIG_BT_RFCOMM_TTY is not set

  1. This is the info of my external bluetooth adapter.
    lamb@lamb-desktop:~$ lsusb
    Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp.
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 006: ID 0461:4d0f Primax Electronics, Ltd HP Optical Mouse
    Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
    Bus 001 Device 003: ID 0461:0010 Primax Electronics, Ltd HP PR1101U / Primax PMX-KPR1101U Keyboard
    Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lamb@lamb-desktop:~$ hciconfig dev
hci0: Type: Primary Bus: USB
BD Address: 00:1A:7D:DA:71:13 ACL MTU: 310:10 SCO MTU: 64:8
UP RUNNING PSCAN ISCAN
RX bytes:658 acl:0 sco:0 events:44 errors:0
TX bytes:2191 acl:0 sco:0 commands:44 errors:0

Does the problem caused by my external bluetooth adapter or system configuration problem? Thank you for your time to help me!

Wrong forums. Please go to the Ubuntu forums for support.