Run Microsoft Windows 10 in Virtual Machine Manager

oh and add yourself to libvirt and kvm groups

2 Likes

I don’t have any games on Steam. The two games are old BF2 mods that are now standalone games free and Fall out 4 and Il2. I was playing this game with Native linux support, but the back ported it to Open GL 3 from 4 for MAC and it has sucked ever since. They had a experimental Vulkan client that was pretty good up until they added this ray tracing scheme that you can’t turn off and now my RTX 2080 can’t handle it any more. I was thinking about getting an auxillary HBM2 device to help it, but haven’t. I’ll try this in the mean time on Microsoft once I get Linux Nvidia proprietary driver reinstalled for 3d hardware acceleration.

It didn’t work until I ran VMM with root privilages. It has to use these auxillary drives. That is why I don’t use STEAM becasue I don’t have room for that on / or /home for it and I can’t put it anywhere else.

But now I have a 222GB MS partition.

Okay. I hope you can get it working as you want. Just be aware of the limitations.

Well yeah. I haven’t tried anything like this, but this’ll be awesome if it works out, but for now I am stuck because current nvidia drive is broke with current kernel. I’ll have to wait for next kernel or nvidia driver.

Well yeah. I haven’t tried anything like this, but this’ll be awesome if it works out, but for now I am stuck because current nvidia drive is broke with current kernel. I’ll have to wait for next kernel or nvidia driver.

And then there is the Xeon phi and the fact that ms vmm only uses 4 threads, but mostly that won’t be a problem just annoying.

Sorry. I missed how you actually fixed the permission issue.
If you do not mind to share…

I entered sudo virt-manager

I let that run for like a day before I shut down and attempted to install Nvidia driver 450.57. It didn’t work and I am still on open source. Microsoft nor Linux is able to use rtx 2080.

I then added my user to kvm group via sudo usermod -G kvm -a $USER sudo usermod -G libvirt -a $USER

Now I am unable to turn it back on. With or w/o root permissions. Using file manger I learn that groups don’t have read/write privileges to the storage device… So I have to Google how to do that with command line. Hopefully that will work.

I entered sudo virt-manager

I let that run for like a day before I shut down and attempted to install Nvidia driver 450.57. It didn’t work and I am still on open source. Microsoft nor Linux is able to use rtx 2080. In MS things will run, but at 15 fps, and not in Linux. I am able to watch videos surf the web and navigate just fine though. Same game, two different clients.

I then added my user to kvm group via sudo usermod -G kvm -a $USER sudo usermod -G libvirt -a $USER

Now I am unable to turn it back on. With or w/o root permissions. Using file manger I learn that groups don’t have read/write privileges to the storage device… So I have to Google how to do that with command line. Hopefully that will work. I saw something with --> chmod +rwx

Append “–no-cc-version-check” to the installer option should work now.

1 Like

I’ll try it when I get home, but when I follow the prompts when installing I always hit ignore. The problem I am having is dkms module fails to build. I haven’t looked at logs yet. So it installs with out dkms, but crashes. I have to uninstall and go back to Nouveau.

I tried yesterday it worked with dkms.

1 Like

It came on after second successful attempt. Crashed the first time.

I ended up deleting it and I’ll try to get one going w/o using root permissions, but it just won’t let me despite having ownership of the file system despite adding my username to kvm & libvirt group.

Have this a read:

,but I am having difficulties here.

ryan@R-BP-CL-GLBWRMRSCCNTR/ $ sudo chown -hR ryan /run

chown: cannot access ‘/run/user/1000/gvfs’: Permission denied

In that directory is the “Storage” drive I am working on so if this doesn’t do it. IDK That thing at the end is negligible, but from here I can make sure everything is part of kvm and libvirt group.

It still return permission Denyed.
root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chgrp libvirt win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chgrp kvm win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chgrp qemu win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chgrp ryan win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chown qemu win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage #

nothing doesn’t work. Permission Denied

more.

root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chmod ug+wx win10.img root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chown ryan win10.img

Even this doesn’t work.

root@R-BP-CL-GLBWRMRSCCNTR/run/media/ryan/Storage # chmod ugo+wx win10.img

Now what I don’t get is: How did I create something, that can’t be used. And if this software is available to use. How do I use it?
Screenshot from 2020-07-30 22-32-14

sudo usermod -aG kvm $USER && sudo usermod -aG libvirt $USER
sudo umount run/user/[your user id]/gvfs/[drive name here]

Or

sudo umount run/media/[ryan]/[Storage]

Or graphically applications>utilities>disks find the drive and unmout. I think it is square for STOP but double check that so you don’t erase it!

Then in terminal run lsblk and find your drive name

Then

sudo mkdir /mnt/mypool
sudo mount /dev/[mydrivename] /mnt/mypool
sudo chown -R ${USER}:kvm /mnt/mypool

You should also be able to add some home directories in virt-manager now without any further changes, and without sudo! (such as ~/Downloads for easily finding isos)

1 Like

Oh and remove old pool in virtmanager and re add as /mnt/mypool

Drives automounted in gnome do not give system and block access bits that are needed for execution and/or qemu/kvm!

Sorry for revisiting this thread. I tried kvm virt-manager for the same type VM install and I getting the same errors as Ryan, running as user, not sudo and trying to install, dedicating a partition formatted as ext4 as storage pool.
Would you be so kind as to tell what exactly all these instructions are to add user (myself) to these groups?
Also, since kvm was installed what caused the user was not added to these groups as part of kvm install… Just to understand all this…
Thanks and Regards…

sudo swupd bundle-add kvm-host \
&& for group in kvm libvirt; do sudo usermod -G ${group} -a $USER done \
&& sudo mkdir -p /etc/profile.d/ \
&& echo 'export LIBVIRT_DEFAULT_URI="qemu:///system"' | sudo tee /etc/profile.d/libvirt.conf \
&& sudo systemctl enable libvirtd --now \
&& reboot

Not every use case is graphical desktop usage and linux package install scripts almost never assume the user installing the package is supposed to be the one using the package. For instance, If I install this on 50 separate hosts using ansible I may want a different user for each machine applied to the group, or in some cases I may only want to allow root or superuser to access.

3 Likes

I see. Thanks again.
Greatly appreciated.

Great stuff again, Kevin.

Thanks a lot! :+1: