Run Microsoft Windows 10 in Virtual Machine Manager

I want to run Microsoft Windows 10 in a virtual machine to play games.

I have Nvidia RTX 2080 graphics and 3960x. I am getting tired of Nvidia proprietary driver install and seeing as Microsoft is readily availible; I thought that this is the best way to go, but I have issues to solve here.

** One I picked up a Intel xeon PHI x1xx just to try. I don’t know if that could help. Seems that there is a lot of software to install for it. ***

But running MIcrosoft Windows 10 in Virtual Machine isn’t working.

It won’t let me install it in the space I need to install it in. Says permission denied.

It doesn’t detect that the Win10 .iso is actually Win10.

If I do get it to start it says insert boot media. it won’t even load the and try and install my .iso regardless of my storage issue I am having. All kinds of problems.

Install a second OS is the way to go.

Do you mean to say that Win10 will not work as a virtual machine under Clear Linux? Would this apply to VMware VM?

I haven’t tryed anything else yet so I don’t know. But last time I did try, I was on this same Clear Linux build except on a dual xeon sandy bridge computer. It knew it was Win10, and I could allocate the storage space for it, but it wouldn’t boot or detect the bootable media inside the VM. So i am still having that problem which is the ultimate problem here.

See I don’t want to be reboot and power cycling constantly just to play games. i want to be able to just minimize it and go somewhere else. Ideally boot up Clear Linux on Intel xeon Phi and run MS on 3960x in VM, but for now I’d at least like to just be able to get MS going in VM with 16 threads.

No. No one does serious gaming in a virtual machine.

That’s becasue they don’t have Clear Linux.

The next logical step here is make a bootable USB. That’s a logical probability for what it needs me to do.

I think doct0rHu makes the point that video support is not sufficient withing virtual machine to play serious games. Such as video cards as part of VM ‘hardware’.
I do agree with that, such as you do not have direct nVidia in VM.
However the original topic was about running Win 10 inside a VM under CL. That should be possible.
In fact I am trying to test it under VMware.
Aside from playing serious games I am curious of performance of Win 10 under CL.
Possibility exists but I will be be able to assess after installation.

What bootable USB do you have in mind? Win 10 or CL?

Agreed on playing heavy games in virtual machine for performance reasons.
Aside from playing games I just tested that Win 10 installs and works just fine in virtual machine under VMware. Video card used within VM is VMware SVGA 3D, which suggests 3D is supported but I do not expect performance to play heavy games. I do not have any games to test but aside from games Win 10 performance within VM seems reasonably good, based on subjective experience. I have not run any benchmarks though.

Seeing how I am on Clear Linux a Win 10 bootable. I don’t want as little ntfs hd space as part of my system as possible. Anyway. I deleted and recreated some of the storage pools that i wanted to use. I’ll put the .iso file in the pool. Maybe that’ll work?

This is my problem.

As much as I think you are pointing to the right place for ISO.
I suggest you move ISO to your user folder such as Downloads and run install pointing to that ISO. Install was smooth and straightforward. I did not experience any issue installing Win 10 in VM and testing performance now.
Surprisingly Win 10 appears to work very nicely under CL. Hardly see any difference from regular install for typical use. But again, I am not playing heavy games…

Most of the games aren’t to heavy I play becasue I have never gamed on Microsoft since about High school [pre Obama] with a few exceptions so latency is the only real issue.

It is one thing if I were at somewhere, but it’s my hardrive with my name on it. I entered a password when VMM started and when I mounted the drive.

Is there away I can integrate the Storage partition with /home? I added it there as /Storage when I set this thing up a year ago.


I just notice that you are using QEMU/KVM as VM infrastructure. I am not familiar with QEMU so perhaps more knowledgeable can help understand this message.
I have been using VMware and had no issue but I am very interested how to accomplish this under QEMU/KVM as you do as I think your choice of VM infrastructure will be still better performance wise.

We may never know… I tried raw…

I don’t have any other options here.
Screenshot from 2020-07-27 20-19-38

My only option here is tar everything up and put it all on this ancient USB 2.0 3TB NTSF drive and repart everything. Can Clear Linux do LLVM?

Success! Took a nap and found the command line form of VMM and that fixed it. I though it would be in root becasue you enter the password when opening through Gnome.

I have to get a NVIDIA proprietary driver installed on CL before it’ll recognize the GPU and I can get the MS drivers installed. Right now I’m on Nouveua. Then I can work on getting all the software for the xeon PHI co processor going.

Found this to be interesting:

** I gave it 16 threads and this is whatI get on MS end. Now on CL it did seem to be rotating through the 16 threads I gave it. Thinks it is an Epyc…

Maybe your permissions issue was related to running virt-managar using sudo? I don’t think it’s necessary sudo to run virt-manager. I actually have Windows 10 installed on a Boxes (gnome-boxes) machine and I run it as an unprivileged user.
Do you play games through Steam? Because if that’s the case, then you may not need to run Windows 10. I’m not a gamer, but I tested a game in my new computer using Steam and it worked. You have to enable the beta features, something like that, which allow you to run many Windows games on Linux.
Also, I don’t think that the virtual machine is going to take advantage of your graphics card, so I wouldn’t bother about which drivers to install as long as it works.


The issue is you are using a drive mounted with gvfs. You need to unmout it the remount manually using root or sudo from cli then give kvm group ownership of the mount.

As far as the graphics you could try gpu passthrough of the descrete nvidia card.