Scanner not recognized

Hi,
I am using clear linux since a few days - it is a very nice OS!
There are some minor issues for me - one is, that my laptop now is not recognizing my scanner anymore. Is there any way to make clear linux to recognize my scanner?
Thanks!

Usually you can go to the official website of the manufacturer and download the driver in rpm format, then extract the rpm and copy its content accordingly. I installed driver for my Brother 2350 DL printer in this way.

Sorry, I am a bit a newbie to clear linux. Was using debian since two weeks ago and am not super elaborated with rpms. Am still trying to get used to the working modes in this distro. How do I extract the rpm and copy its content?
Thanks for your help!

Before you do that, can you help us see what scanner you have? We might just need to enable another driver to support it.

If it’s a USB device, just run lsusb and paste the line for your scanner.

Shure:
ID 04a9:190f Canon, Inc. CanoScan LiDE 220

According to http://www.sane-project.org/sane-mfgs.html#Z-CANON
CanoScan LiDe 220 is supported by sane-projects.

I don’t have this device so I cannot try this myself. But on other distros you can install packages related to sane or xsane. I searched with swupd search-file -l sane and find that the bundle hardware-printing contains libraries related to libsane.

You may try to install sane according to this guide and see whether you scanner can be recognised.

Correct, the hardware-printing bundle (also desktop-kde-apps and digikam) contains the SANE Genesys backend for this scanner.
http://www.sane-project.org/sane-mfgs.html#Z-CANON

1 Like

Does this mean, that my scanner should work, if I got the relevant bundles installed?

Yes. Please give it a try and let us know how it works :slight_smile:

Such kind of recognization errors are quite frequent the users are getting these issues. To recover these troubles can take suggestions from Canon Printer Error Code 5b02 that will be beneficial for them.

Did not work :frowning:

Can you give us more information, such as what you tried, what happened, any error messages, etc.?

Install Mixer bundle we have rpm.
We can’t use “rpm --install package.rpm” to other software unavailable in Clear Store, the same way we do on Fedora Silverblue (rpm-ostree install package.rpm)?

You can use

rpm2cpio <RPMFILE> | cpio -divm

to extract the rpm files, then copy to a proper location.

1 Like

The hardware-printing bundle was already installed on my computer. I installed the digicam bundle and did hope that that would make my sane genesys backend work. After plugging in my scanner, I tried, if simple scan is now recognizing the (device) like it used do, when I used other linux distros. Unfortunately that was not the case.

What’s the output of

scanimage -V
scanimage -L

scanimage -V
scanimage (sane-backends) 1.0.27; backend version 1.0.27

scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Please try running scanimage -L as root; there may be a permissions problem.

If that doesn’t help, can you try creating /etc/sane.d/genesys.conf and adding the following line to it?

usb 0x04a9 0x190f

The genesys backend may not be automatically searching for supported scanners.

1 Like

Related issue: https://github.com/clearlinux/distribution/issues/647

Fix has been implemented; you’ll see that issue updated when the fix is released.