[SOLVED] How to handle USB Floppy Drive? (formatting, mounting, etc)

I bought USB FDD Floppy drive. It is recognized but I can not make it to run/mount.

Trying to mount or format:

I read that I need a “floppy” kernel module. But I don’t know where I can get one.

kj@ibm-beast~ $ sudo modprobe floppy
modprobe: FATAL: Module floppy not found in directory /lib/modules/5.1.14-788.native

UPDATE: I tested on POP!_OS (Ubuntu) and run:

sudo ufiformat /dev/sdc

It does make a success format. But the floppy is still not recognized. And I can not format it:

sudo mkfs.fat /dev/sdc
attribute "partition" not found
mkfs.fat: unable to discover size of /dev/sdc

I tested on two floppies (do not have more at the moment). There is a chance that both don’t work.

$ sudo ufiformat -i /dev/sda
vendor:  MITSUMI
product: USB FDD
write protect: off
media type: 2HD
status      block size   kb
unformatted  2880  512 1440

Oddly enough, I have done this before:

sudo ufiformat -f 1440 -v /dev/sdb

This is for 1.44MB floppy disk, if you are using a 720KB just change “-f 720”.

1 Like

USB3 floppy drive or USB2?:joy::joy:

I did this. It get thru the whole floppy. But after that the floppy do not work (“can’t read superblock”).

Don’t tell me there are usb3 floppy drives? ;o

1 Like

I tested the external drive at windows machine at work and it has was exact same problems. One floppy did not work at all, second was trying to format but after couple of seconds ends with error. They are 20 years old. On Linux ufiformat gets to the end.

I will buy a new pack of floppies (not so easy to get those days). And then if all fail I will buy another external drive (new this time).

Summary on Debian Linux (I tested both /dev/sdc and /dev/sg2, doesnt metter):

$ sudo ufiformat -i
disk         generic     
/dev/sdc     /dev/sg2    

$ sudo ufiformat -i /dev/sg2
vendor:  MITSUMI
product: USB FDD
write protect: off
media type: 2HD
status      block size   kb
unformatted  2880  512 1440

$ sudo ufiformat -f 1440 -v /dev/sg2
format on device=/dev/sg2, size=1440
geometry: track=80, head=2, sector=18, block=512

Everything looks good but when trying to mount:

$ sudo mount /dev/sdc /media/floppy/
mount: /media/floppy: can't read superblock on /dev/sdc.

After ufiformat, you must still make a vfat filesystem:

sudo /usr/bin/mkfs.vfat /dev/sdb

I hope this helps and it isn’t your floppies. :smiley: Cheers!

I’m not joking - I’m pretty sure we disabled floppy support in our kernels at some point. Be as that may, I do have a pile of old hardware in a drawer at work where discarded cables and small electronics are enacting a toy story-like epic drama. I’m fairly sure there’s a USB floppy drive in it, so, maybe I can try and see if we do still support floppy drives, or not. Of course, I’d still need… an actual floppy disk itself.

1 Like

No luck also:

$ sudo mkfs.vfat /dev/sdc
mkfs.fat 4.1 (2017-01-24)
attribute "partition" not found
mkfs.vfat: unable to discover size of /dev/sdc

It is working as it gets different message without any floppy:

$ sudo mkfs.vfat /dev/sdc
mkfs.fat 4.1 (2017-01-24)
mkfs.vfat: unable to open /dev/sdc: No medium found

I’m doing it right now on different distro (POP!_OS) but as I remember it was exact same on CL.

EDIT: pack of new unsealed FDDs are on the way. There’s a chance I will have them on Saturday.

1 Like

I bought a new, unsealed pack of FDDs. Formatted for DOS. Exact same errors.
I read a lot here and there and most Linux programs do not support USB drives. And I need USB as non of my computers (even servers) do not have floppy connection (it wasn’t ATA as I recall but still I only have SATA and SAS connectors).

I’m afraid my floppy project will fail :frowning:

What if I test some very old Knoppix? Those days floppies were still around. It will not fulfill my project (as I need a modern PC) but at last I will test if this drive works.

EDIT: Knoppix 8.2 w/ 4.16.5 kernel gives me exact same errors. I’m starting to feel that it’s the actual drive problem. As it is recognized by all OSes with no problem but just do not want to read floppies.

Also udisks generates same error.

$ udisksctl mount -b /dev/sdc -t vfat
Error mounting /dev/sdc: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error mounting /dev/sdc at /media/kj/disk: can't read superblock on /dev/sdc

EDIT2: I finaly opened the USB drive to reveal the real problem:

Ordered new drive. This time new. It will arrive probably Tuesday. I will report.


I bought new external FDD drive and now It works as expected. At last on Ubuntu based system. I will test on CL later today. But judging on the experience it was 100% problem with the broken drive and now it will work as any other mass storage on GNU/Linux.

I will confirm this and the topic could be closed as solved. The bright site of this is that I now know all the low level commands to work with FDDs :slight_smile: Thanks to all who helped.

EDIT: works perfectly fine! I’m very happy to hear those “floppy noises”. Lot’s of nostalgia. That moment when after [save] (or :w) you literally hear the data being write :slight_smile:


Here’s my experience today with an actuall floppy drive (3.5"). I had this tucked into the cellar of forgetfulness (a drawer at work where I occasionally “store” weird stuff).

Plugged in the FDD - it’s a USB mass storage device. Clear Linux recognizes it and /proc/partitions shows a 1440 #blocks block device. So far so good - that just means it’s all just software from there.

Gnome shows the floppy disk in Nautilus. Clicking on it mounts it. On it are a few files already, who knows what’s on this drive. Maybe it’s the blue print from a 386, or some secret spy hardw… ah no, it’s just a firmware update for an old compal device I apparently still have tucked in the same drawer too.

I’m gonna leave it plugged in and read some sectors though. bzztt tik tik tik brrrr kggggg rrrrrrrr…