Suspend Error on Yoga slim 7i

Hi everyone,
I’ve a problem with Lenovo Yoga Slim 7i suspend with Clearlinux version 35940
The problem is when I enter the command

systemctl suspend

the below error message shown to me:

Failed to suspend system via logind: Sleep verb "suspend" not supported

what can i do?

There are a few threads on suspend issues on the forum. What you describe sounds similar to this Suspend and hibernate and if you get past that check Are there known sleep issues with Clear Linux?
Remember that Clear Linux is focused on server applications, and suspend is not a typical server use case. YMMV.
Chris

thank you pixelgeek,
but i’m using desktop version of clearlinux,
and none of the threads you mentioned about them, dont respond my problem

Create a new file in /etc/kernel/cmdline.d

sudo nano /etc/kernel/cmdline.d/suspend.conf

Add this line and save the file (ctrl X)

mem_sleep_default = deep

Update the boot parameters with :

clr-boot-manager update

Reboot.


Install powertop :

sudo swupd bundle-add powertop

Navigate with the TAB key to the Tunables screen.

Navigate up/down with arrow keys, toggle status with Enter key.


Tweak bluetooth manually or with a GUI.

If it still refuses to go into deep sleep, temporarily stop or disable bluetooth
(sudo systemctl enable / disable / start / stop bluetooth gnome-bluetooth)

1 Like

thanx businux,
this solution

made my laptop screen blank(black) after running

echo mem>/sys/power/state

command and only way is turnoff via powerswitch! :pensive:

before adding this parameter to kernel, my laptop shows going to sleep (power led blinks) but battery consume continues and laptop warms.

Did you use powertop as i suggested ?

yes and toggle all bad to good but no effect in issue seen.

There’s a few suggestions in this AU thread (dbus and polkit) :

Unfortunately ALL of methods in this thread dont work in CL :pensive:

Not on a Lenovo Yoga Slim 7i (yet).

Looks like the Yogas are problematic with other Linux distros too :

https://forums.lenovo.com/t5/Other-Linux-Discussions/Yoga-Slim-7-cannot-enter-deep-sleep-S3-state-aka-Suspend-to-RAM-on-Linux/m-p/5039060

Yes this is Yoga Slim 7i,
Before CL I was using ubuntu 21.10 and I’ve no problem.

Better not run default UB in the cloud then. :wink:

:thinking:
What you mean?
I dont understand the sentence

The last thing you want, running a cloud or other web service, is deep sleep / hibernation :slightly_smiling_face:

Just use what works for you…

If you want to speed up Ubuntu, install the XanMod kernel, it includes the major CL optimizations.

1 Like

I’l test it
Thank you for your time and SUPER FAST responses :wink:

1 Like