Unable to access GPU video engine with NVIDIA 520.61.05 aka CUDA driver

I tried this before and had same results, but here it goes…

So I had 515.76 and I was able to stream via nvenc x264 and record via hevc_nvenc and also a built in nvenc into OBS that wasn’t custom. SO I uninstall the old driver and install the new one via

`ryan@CLR-BP-GLBWRMRRSSCC~ $ sudo sh ./cuda_11.8.0_520.61.05_linux.run --silent --override
`

I boot in and it works and all. THis is with OBS.
Here are two videos for proof it worked.
The first one is a copy and paste from the stream from twitch.

The second is a video using OBS’s built in hhevc_nvenc…

It worked. OBS can’t access driver. I tried to install mango hud and it was unable to find NVCtrl.h

nor with Green with Envy nvml share librarys will not be found. These are all normal bugs and all. It is just if I uninstall that CUDA driver this stuff will all work excluding MangoHud because I do not know and have never used it before. SHould I keep using the driver here? Can I count on this being fixed or do I have to continue using the game ready drivers.

FYI FFMPEG VAAPI has never worked. I don’t know what to do to get that going, or if that is evan worth it or not.

If I manualy add in custom output hevc_nvenc it says permission denied

Screenshot from 2022-10-05 15-48-02

I can still access fan control as well as mem speed and gpu clock



1 Like