Using Clear Linux as a daily driver issues

Hello ,
I’ll try to be short , as full linux noob last year I decided to jump from Win7 to Clear Linux as a daily driver on my dekstop Ryzen 5800X3d , X570 mobo , Nvidia GTX 1080Ti , Creative X-Fi Titanium audio.
I was very impressed worked around the quirks in 2 months time , setting up the proprietary Nvidia drivers putting their scripts at easy location so I can reinstall them every time they got broken by update , switched to Pipe Wire so I can use Easy Effects for audio tune up.And most important thing that I always do no matter the OS if it works stable disable the Auto Update and go manual only when needed.Generally working through remote to my office machine , browsing , playing Steam native and other windows games through Lutris , except from the lack of native ffmpeg which would get higher quiality remote video stream all was fine and worked as expected.

From October to April all was fine till Easy Effects complaint it wants newer version of Pipe Wire and then I decided against my internal feelings to update. Got the new then Gnome 44 and issues started. After installing proprietary NVIDIA drivers when going to Settings > About it is reporting on Graphics that it is running in “Software Render” also Windowing System is “X11”. Expected “gnome-shell” consumes almost constantly 20% CPU for simple Alt+Tab and minor changes on the screen and sometimes up to 40% (this is not the case when using the “nouveau” driver) , I tried to revert to previous version of clear linux with “swupd” but it was unsuccessful so went back to the latest back then and started waiting for things to get better but they never did in this regard yes nautilus issues got fixed and in general GNOME 44.3 is working fine.

So I was ok let’s go to wayland - no way to make it start with wayland the gear on the login screen is missing and I don’t know since when. I tried through gdm custom.conf in both locations “/etc/gdm/” and “/run/gdm/” to enable wayland , used the newer scripts to install NVIDIA drivers cause there is now Wayland related configuration there that more or less is doing what I did manually.And all for no avail I was unable to start under Wayland the only think I can observe is a bit delayed start and a single screen flicker on login but it is with X11.So yeah I’m not sure if in order to try and see if under wayland I’ll get my UI hardware acceleration back with NVIDIA drivers I can do anything more or I need to make clean install of Clear Linux.

Other issues that appeared a little bit more than 2 weeks ago are long login times from the moment you enter your password to the moment the desktop appears which under “nouveau” are with screen available and under NVIDIA is on black screens. Also the old SATA NTFS drive started dissapearing sometimes requiring a couple of reboots to appear or boot to windows 7 reboot into clear linux to make it visible in Nautilus.

So If any of you want to engage in giving propositions to this issues remember I’m noob linux user. :slight_smile:

:+1: very impressive for rookie )

Login time was cut down in half the waiting time with build 39810. :slight_smile: Still it is not instant as it was month and a half ago.