Any game on Lutris fails to start

Hello, when I try to start any game in Lutris I get this error:

/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdout = io.open(c2pread, 'rb', bufsize)
2020-01-13 22:38:52,001: Game still running (state: running)
2020-01-13 22:38:52,001: Stopping Cemu (wine)
TypeError: refresh() takes 1 positional argument but 3 were given

Any ideas what might be wrong?

Did this work before? Is this purely wine games?

I don’t know if it worked before I installed today. No this in on Dolphin runner too.

This is the output of Resident Evil 2 ran via Lutris. The game starts normally via Steam.

/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdout = io.open(c2pread, 'rb', bufsize)
Running /usr/bin/steam steam://rungameid/883710
/usr/bin/steam: error while loading shared libraries: /usr/lib64/libc.so.6: cannot allocate memory in static TLS block
Waiting on children
Exit with returncode 127
2020-01-14 09:16:32,037: Full shutdown prevented
2020-01-14 09:16:33,983: Game still running (state: running)
2020-01-14 09:16:33,984: Stopping RESIDENT EVIL 2 / BIOHAZARD RE:2 (steam)
TypeError: refresh() takes 1 positional argument but 3 were given

I noticed this around the same time (python3.8/lutris updates) too. Games just immediately exit. The best workaround I have been able to find is to disable Prefer system libraries under System options.

Has there been any update on this? Cause I’m still getting the same issue and it’s the only thing preventing me from using Clear Linux as my daily driver. :frowning:

Nobody is looking into this. I don’t own RESIDENT EVIL 2 so I can’t test your problem either.

Oh, I’m sad. :frowning:
Ok, I think this a wider problem as I can’t play any emulators either so it happens with more Steam games too most probably. I think it would be really nice to be able to just install the system and be able to just play games, especially with the performance optimizations of Clear. A lot of gamers would check it out. :smiley:
Oh well, thank you very much for the reply and hopefully this gets fixed in the future. :smiley:

Ok so I have found a solution for steam games (emulators still won’t start). You have to install the flatpak version of Lutris in order to make things work. So you type in the following commands:

flatpak remote-add --user flathub-beta https://flathub.org/beta-repo/flathub-beta.flatpakrepo
flatpak update --appstream
flatpak install --user flathub-beta net.lutris.Lutris//beta
flatpak install org.gnome.Platform.Compat.i386

This way Steam games run just fine with gamemode enabled too.

For Dolphin I get the following error:

error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory

If anyone has any ideas please let me know. :smiley:

1 Like

Try to build it from source. It’s the best way.
And it brings some nice lessons to learn in the process. :nerd_face:

https://wiki.dolphin-emu.org/index.php?title=Building_Dolphin_on_Linux

For dependencies you cannot find in CL, use https://pkgs.org .