Clear Linux ISO Not Booting

I’ve been using Clear Linux as a main OS on my Intel NUC and Lenovo Yoga 920 for a while now and so far everything has worked very well or at least been easy fixes.

However, I just got Dell XPS 2-in-1 (7390), and despite days of trying I can’t even get the ISO installer to boot on the computer. Has anyone had any success getting Clear work on the new Ice Lake XPS?

That’s surprising. Does the boot menu show the USB UEFI device? What exactly happens? Did you check the BIOS settings to enable booting from USB?

It boots to the menu where you can either select to continue to boot to Clear Linux or reboot into UEFI interface (Systemd boot menu I believe). Once you choose to boot Clear Linux it stalls the computer with black screen and nothing but hard reboot gets the laptop going from there.

BIOS settings should all be good to go.

1 Like

Based on your description you don’t have your boot installed/loaded correctly. I would definitely double check to make sure your bios is not set to “Legacy”.

And, silly I know, make sure you’re writing to the correct intended disk. Because your boot process isn’t recognizing your hard drive.

No, I don’t think so, he wrote that he’s seen the clear linux boot entry, which means he’s already booted into UEFI mode to the bootloader.

1 Like

This suggests gpu firmware may be missing or another graphical issue. You can try to boot with nomodeset and seeing if you can at least boot to a text console. Also remove quiet to see a little more verbose output.

1 Like

Touché @ahkok I missed that

Alright I double checked all the BIOS settings and created a new boot USB from the latest download available from the Clear Linux website. The system now freezes after “Found installer media, continuing boot…” appears on the screen. Again, only way out seems to be hard reboot.

Have you checked if you have the most up to date bios? Looks like acpi errors. You might have to add

noapic acpi=off

To the kernel boot parameters.


Press ‘e’ when the boot manager first appears from there add those lines at the end of the current boot parameters.

Thank you very much! I tried the suggestion and it freezes with black screen again with noapic acpi=off parameter. I’ll try to play around a bit more with the boot parameters later today.

This image indicates a successful boot to text-mode. Try pressing alt-f2 and seeing if you can login as root for instance.

Thank you all for suggestions! I was able to boot to installer media today by adding modprobe.blacklist=intel_lpss_pci to the boot parameters. It seemed to work fine but there was no wireless connectivity. Will perform full install later today and see how it goes from there.

1 Like

Can confirm that once installed on XPS 7390 2-in-1 everything works out the box except bluetooth and touch screen. Will tinker around and see if I can get those 2 to work.