Clear Linux not booting. How to Debug

Suddently clearlinux is not booting for me. It get stuck at

I tried fixing broken install using
Only diference is now I’m getting the bluetooth line. It was not there earlier.

Can someone pls help me debug the issue.


Update your BIOS and reboot.

If it still hangs, disable Bluetooth/Wireless in your BIOS to compare output.

There is no new update for BIOS. Its an old laptop. Last update available is 2018.
The bluetooth issue is driver related. It never stopped the laptop from booting.

Any other way to debug ?

It’s related to this :

Try different settings for Fan / Power in BIOS.

Try holding the spacebar, there might be older kernel versions that you might be able to boot… Another option is a broken X11/GDM, can you Ctrl+Alt+F1,F2,F3…F12?

When I have those kind of issues, I boot with the previous kernel available that worked until there is a fix, like @Gustavo_Peredo suggested.
In my case, I have to press the escape (Esc) key instead of the space bar.

@Businux I formatted my system and reinstalled clearlinux. Now its booting up fine with same warnings. So those errors do not stop clearlinux from booting. It was some different issue which was causing clearlinux to not boot.
@Gustavo_Peredo @stefano Thanks for suggestion. I didn’t knew about holding space and booting with different kernel. I tried with multiple kernels but none of them booted. Also I use LTS and the version in my earlier install is different than my current fresh install. That may also be a possible culprit. But now we will never know :smiley: