Corrupt(!?) filesystem on new install

I got the following error just as the desktop crashed on a fresh install. So far I have updated the system, and the error appears to occur once the next version is available…

I want to believe it’s related to the disk/file system (or maybe it’s related to the upgrade process?) but I am not savvy enough to draw any conclusions.

Any insight is appreciated.

Welcome to the club!
It is a compatibility problem with your NVMe drive.
I will keep it short and give you the answer I found, which works by the way.

You have to disable the power management feature of your NVMe.
For that you need set a parameter in the kernel options.

Here are the steps:

  1. Create the directory
    sudo mkdir -p /etc/kernel/cmdline.d/
  2. Create a configuration file in the above directory with the proper parameter:
    sudo echo "nvme_core.default_ps_max_latency_us=0" > nvme.conf
  3. Update the boot manager
    sudo clr-boot-manager update
  4. Reboot

This should solve your problems.
I didn’t file a bug report yet. But I think I will.

2 Likes

And by the way, you can trigger this behavior you described with the upgrade command.
It provokes the problem each and every time.

1 Like

Cheers!

Just to make sure; I created a file called “nvme.conf” inside that folder and pasted “nvme_core.default_ps_max_latency_us=0” (including “”) as text inside the file and saved, executed the clr-boot-manager command and did a reboot.

All fine and dandy?

Regards,

Yep. You should be good.
To verify that the parameter is correctly set, you can do sudo cat /proc/cmdline and have in return something like this:

initrd=\EFI\org.clearlinux\freestanding-00-intel-ucode.cpio initrd=\EFI\org.clearlinux\freestanding-i915-firmware.cpio.xz root=PARTUUID=dd263a90-9859-400a-be2b-3ebb9d2c9209 quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests init=/usr/bin/initra-desktop initcall_debug intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check noreplace-smp page_alloc.shuffle=1 rcupdate.rcu_expedited=1 rootfstype=ext4,btrfs,xfs,f2fs tsc=reliable rw nvme_core.default_ps_max_latency_us=0

The last part being the parameter you added.

And to test if it is really working, the best is to wait for an upgrade of Clear Linux and then trigger this command: sudo swupd update
If it works, then you’re good.

1 Like

I’m just looking more thoroughly at you comment.
In the file nvme.conf, there should be not quote (").
Apart from that, all good.

After setting boot parameters, you only need

clr-boot-manager update

Yes, you’re right.

The sudo swupd update is the perfect trigger to make Clear Linux crash every time when you have this problem with the NVMe.
If it doesn’t crash this way, it means you’ve got no problem with your NVMe.

Don’t ask me what kind of sorcery is done in swupd (IMHO badly named by the way), so that it makes it crash 100% if the time.

I have nvme but it doesn’t crash.

You’re lucky.
What NVMe drive do you have?

Thank you very much, both of you.

I have corrected the errors and I will be testing the solution tomorrow.

It’s indeed a little odd the install crashes because of the drive…? In my mind it’s perfect setup to run Clearlinux on an Intel NUC.

It’s a Kingston A2000 (256GB) installed inside a 10th gen NUC. (I can look up the exact product ids if it’s of any interested to someone).

Samsung 960 Pro
It never had problem

You had the chance to chose the right piece of hardware for your mainboard.
Lucky you :wink:

1 Like