Disable Mitigations (Spectre/Meltdown/Etc.)

I used the below shell script courtesy of @doct0rHu to disable mitigations on an 11700-K running the latest Clear Linux Server, but it didn’t seem to have any effect on numerous performance intensive benchmarks:

[ -d /etc/kernel/cmdline.d ] || \
    sudo mkdir -p /etc/kernel/cmdline.d && \
    echo "mitigations=off" | sudo tee -a /etc/kernel/cmdline.d/SOMEFILE.conf && \
    sudo clr-boot-manager update

I suspect mitigations were not successfully turned off, even though I’d created /etc/kernel/cmdline.d/SOMEFILE.conf that specified they were. Does anyone have any ideas for how to successfully disable mitigations, specifically on Clear Linux? Thank you!