FATAL BOOT ERROR: Nvidiafb: cannot requests PCI regions

Refer to Blank Screen on boot: "nvidiafb: cannot request PCI regions" for discussion background.

After switching from a dual display setup to a single display setup, this boot issue seemed to be solved.

The issue returned immediately upon clicking the suspend button available from the power menu, represented by a pass-button icon. When the system suspends, I cannot get it to recover, so I must hold the physical power button to initiate a reboot. When the system reboots, I come to the same blank screen with a blank cursor that does not offer the ability to enter a TTY.

For clarification, my hardware is as follows:
Intel 7700k CPU
Asus Z270i MOBO
MSI Nvidia 1080Ti GPU
32G Gskill Ripjaw V RAM
2x Samsung 960 pro M.2 SSD

I do not expect that this will be simple to diagnose, but I think this is a notable issue that may become of use for future compatibility and bug fixes.

Please tell me your thoughts on this, and definitely reply if you are experiencing a similar issue to provide insight as to how prevalent this error is.

Thank you,
Neekon Saadat

It’s been reported that after installing the NVIDIA proprietary driver, you will encounter error if you connect a display to the motherboard. But you can still have multiple display with only one GPU.

The problem with suspension had happened to me when I connect the display to my integrated GPU. Do you connect your display to NVIDIA GPU or motherboard GPU?

As for the blank screen after the reboot, have you tried to press CTRL + ALT + F3 to go to tty?

With my current install of clear Linux, I tried to avoid repeating this issue from the first installation by abstaining from installing the Nvidia drivers, so the system has only what the os comes with out of the box. I am connecting my single monitor to my GPU, not the motherboard. Lastly, none of the tty’s will activate, which does make this issue harder to resolve. I know that the system isn’t broken since I spontaneously recovered from it last time when I switched from dual to single monitor, but that no longer seems to help.

Correct me if I were wrong.

Currently you have a fresh installation with native Nouveau driver, which is not blacklisted.

And you were able to boot up with the display connect to the NVIDIA driver, but the system cannot wake up from suspension.

Then you rebooted the system but get stuck with a blank screen.


Did you try to connect the display to your motherboard?

Silly me. You are soon on the the problem description, and connecting to the mobo on onboard graphics works. I will now try to install the Nvidia graphics to see if I can get the system running with my GPU. Thanks!

1 Like

Once you’ve installed the proprietary driver, you will want to shutdown the system and connect the display to NVIDIA GPU before you rebooted.

There’re reports that if you still have display connected to motherboard after installing Nvidia driver, you will see an error when your system boot up.

I just got this issue. In my case, things were working great until I shut down my computer and unplugged everything.
When I plugged everything in again, the Clear VM booted with a black screen. Then I switched from the DisplayPort to HDMI and saw the error.
It also says ‘kvm: no hardware support’.

You mean you installed NVIDIA driver?

1 Like

Correct, and reinstalling it fixed the issue.

great. there’s no other issues, right?

Nope. I still don’t understand why switching interface caused a problem, but maybe that’s a question for NVIDIA.