FreeRDP or other remote desktop solution

Guys, it’s been impossible to find a remote desktop solution for CL (Wayland) so far. The FreeRDP that comes with any of the bundles is too old to work (or, anyway, it doesn’t work for me). AnyDesk does not work w/Wayland. NoMachine has not been ported to CL, and I can’t see that happening anytime soon.

What are you guys using for a remote desktop server (no matter what protocol) in the CL environment?

@Aqua1ung Remmina any good? I have not used it but seems to come with Clear Linux. The cogwheel at login even have a Remmina Kiosk option.

Thanks. Remmina is just a client. What seems to be missing from CL is a good remote desktop server. Clients are a dime a dozen (or thereabouts). Also, the GNOME Remote Desktop software that comes w/GNOME seems to be either broken in CL, or it’s simply missing completely

Have you tried :

Thanks. Seeing as VNC seems to be on its way out, I’d be keen to look for some remote desktop server that does not rely on it.

[Edit: does xpra work with Wayland?]

I assume you are looking for a graphical solution (I.E. not SSH?). Have you tried xrdp? I haven’t seen it mentioned yet, and I’ve had good luck deploying it at work. And if you use a windows desktop, no extra applications needed

It’s in x11-tools.

Thanks, I am trying xrdp as we speak. Unfortunately I do not see any documentation, so other than installing it and starting the service (something I had to guess that it needs to be done), I don’t know what to do next. So I do have xrdp on my CL (Wayland), and I have been attempting to connect to it using Remmina. So far it has not worked: here’s what systemctl status xrdp shows:

dad@DadsGram~ $ systemctl status xrdp
● xrdp.service - xrdp daemon
     Loaded: loaded (/usr/lib/systemd/system/xrdp.service; enabled; preset: disabled)
     Active: active (running) since Sun 2023-03-19 14:31:33 EDT; 3min 26s ago
       Docs: man:xrdp(8)
    Process: 30478 ExecStart=/usr/bin/xrdp $XRDP_OPTIONS (code=exited, status=0/SUCCESS)
   Main PID: 30479 (xrdp)
      Tasks: 1 (limit: 38133)
     Memory: 1.0M
     CGroup: /system.slice/xrdp.service
             └─30479 /usr/bin/xrdp

Mar 19 14:34:46 DadsGram xrdp[30732]: [WARN ] Received [MS-RDPBCGR] TS_UD_HEADER type 0xc006 is unknown (ignored)
Mar 19 14:34:46 DadsGram xrdp[30732]: [WARN ] Received [MS-RDPBCGR] TS_UD_HEADER type 0xc00a is unknown (ignored)
Mar 19 14:34:46 DadsGram xrdp[30732]: [INFO ] xrdp_load_keyboard_layout: Keyboard information sent by the RDP client, keyboard_type:[0x04], keyboard_subtype:[0x00], keylayout:[0x00000409]
Mar 19 14:34:47 DadsGram xrdp[30732]: [INFO ] xrdp_load_keyboard_layout: model [] variant [] layout [us] options []
Mar 19 14:34:47 DadsGram xrdp[30732]: [INFO ] Non-TLS connection established from port 43298: with security level : high
Mar 19 14:34:47 DadsGram xrdp[30732]: [ERROR] received wrong flags, likely decrypt not working
Mar 19 14:34:47 DadsGram xrdp[30732]: [ERROR] xrdp_sec_recv: xrdp_sec_process_logon_info failed
Mar 19 14:34:47 DadsGram xrdp[30732]: [ERROR] xrdp_rdp_recv: xrdp_sec_recv failed
Mar 19 14:34:47 DadsGram xrdp[30732]: [ERROR] libxrdp_process_data: xrdp_rdp_recv failed
Mar 19 14:34:47 DadsGram xrdp[30732]: [ERROR] xrdp_process_data_in: xrdp_process_loop failed

So, what am I doing wrong? What am I missing? Is there any configuration to be done for xrdp? Am I missing any bundles (my CL installation is very conservative)? Am I missing any dependencies?

No direct solution, but some clues here :

1 Like

I haven’t poked at xrdp in Clear Linux yet. I’ll try to do so when I have some free time. When I installed it on rocky linux, the two main config files were /etc/xrdp/xrdp.ini and /etc/xrdp/xrdp-sesman.ini - I’d look for those.

I have also been looking closely at xpra, though it seems that that one suffers form major issues. Did anyone manage to make xpra work in CL (Wayland)?

Hi @Aqua1ung, I understood that you are looking for a remote desktop solution, but I still need to ask why?

At least in my experience, ssh solutions are much more robust. Are you sure that connecting via ssh and enable Xserver forwarding won’t solve your problem?

@rfkspada: Let’s say I am one of those used to “click their way to happiness” :grin:. (Yes, I know, what am I doing in Linux land, right?) Plus, I may need to offer tech support for my family members, now that I’ve switched all my family computers over to Linux.

Nevertheless, if we have at least two promising remote desktop packages (xpra and xrdp), why not use them? And they look to be pretty recent (hence not abandonware): surely, whoever went to the trouble of porting them to CL must have tested them, right?

Interestingly, there is no /etc/xrdp/ folder. I did find two files xrdp.ini and sesman.ini in /usr/share/defaults/xrdp. (Again, note that the “sesman” file is not titled xrdp-sesman.ini but simply sesman.ini(!))

With this being said, have you had a chance to poke around the xrdp bundle?

Only briefly - I tried playing around with it in a container, but ran into some limitations. I’ll poke around in a VM or a physical install soon, see if I can’t get a working config set for you, I have it working well on Rocky Linux, but it comes with some working defaults.

I apologize, idk when I’ll get to it.

1 Like

Well, well, well … what have we here!! It looks like the CL gods finally relented and (a) updated FreeRDP(!) and (b) released none other than the one and only … gaspgnome-remote-desktop!!!

1 Like

Sadly, I have not been able to make gnome-remote-desktop work on CL 38700. Does anyone else care to share his experience in this regard?

Maybe Vinagre would be more suitable for you? It’s easy to use. To establish a connection, you need to select a protocol from the menu and enter the IP address of the target server. Once you are connected, you can simply view its screen or interact with its graphical interface.
If this option doesn’t work for you, you can check out This article describes many tools.

Thank you. The issue with CL is not so much the lack of a remote desktop client, but the lack of a good reliable remote desktop server. The good ones I know either have not been ported to CL, or do not support Wayland (TurboVNC, e.g.).

Don’t know if it can be used for a full remote desktop, but you could try Waypipe

Although you prefer RDP above VNC, for Wayland there’s WayVNC