HP Envy 15 x360 Laptop

Let me first start off by getting this out of the way right off. The HP Envy 15 x360 is a POS. Always has been, always will be. Windows 10, works okay, but even then not great. I have been trying to get any distribution of Linux to work on this off and on for the past several years. Nothing has worked completely. I have been able to get distro’s to work, but they have all had one or more issues. And not a one has ever worked with the internal wireless card. The internal card is a Intel Dual Band Wireless-AC 7260. I just discovered Clear Linux a few days ago and thought I’d give it a try. Can’t hurt. Booted up the live image, and EVERYTHING worked. First time ever! Clear Linux even detected the screwed up ACPI in the BIOS and disabled it when it booted! Wireless came up 100% fine. Now that excited me. I went and installed this following the doc’s. Installation went perfect. I finished the install and rebooted the laptop. Booted up just fine. Went to move the mouse over to the login box, and mouse didn’t work. Okay, hopefully not a big deal. Plugged in a USB wireless mouse, 5 seconds later mouse was working. Went to the login box to login, whoops, the keyboard doesn’t work. Plugged in a USB keyboard, 5 seconds later it was working. Well maybe once I login the first time all the hardware will be detected and added. Nope. Tried all the usual troubleshooting. Module loaded for wireless? Yep. Detected? Yep. rf-kill status, soft/hard blocked, just like always. All this brings me to this question. How can all the hardware be detected, all drivers loaded, and everything working on the live image, but then to have so much not work after installing the system? I am just at loss. I’m not a Linux expert, but I’m not a newbie either. I’ll take any advice any one can offer both on why the live image works, but the install does not, and how to get that horrible internal wireless card to work.
Thanks.

This is really intriguing…

You should change some IWLWIFI settings to fix this.

Your card runs both wifi and bluetooth at the same time, even if disabled in OS settings.

Normally you’d create or modify /etc/modprobe.d/iwlwifi.conf

bt_coex_active=0 power_save=0 swcrypto=1 often fixes a lot of problems.

Check this thread : http://forums.debian.net/viewtopic.php?t=121696

2 Likes